summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2018-09-26 19:42:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 20:14:43 +0000
commite215480cffe33f78d50757c27a97aa4c32403a97 (patch)
tree55d48259179ed786cfd6f7aa8f35f4d07517f1d8 /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb
parenta1130dca9c6350ac2fe7e37701a301fe3fc79435 (diff)
downloadpoky-e215480cffe33f78d50757c27a97aa4c32403a97.tar.gz
gstreamer1.0-python: upgrade to version 1.14.3
(From OE-Core rev: 750e03a231eb3bcf31c30cf67ff80a6bc821ee66) (From OE-Core rev: 5220cda51a22536f2d64a655ffeecd756d042dc5) Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb
new file mode 100644
index 0000000000..d42c9196e7
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.3.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "af6907b1b6c41a52b27939417e8c5ba9"
10SRC_URI[sha256sum] = "4fc3e76c965384e54fb6be819d606ab304988eb677cf0c5dcc0dd555e3ad8307"
11
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
19inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection
20
21do_install_append() {
22 # gstpythonplugin hardcodes the location of the libpython from the build
23 # workspace and then fails at runtime. We can override it using
24 # --with-libpython-dir=${libdir}, but it still fails because it looks for a
25 # symlinked library ending in .so instead of the actually library with
26 # LIBNAME.so.MAJOR.MINOR. Although we could patch the code to use the path
27 # we want, it will break again if the library version ever changes. We need
28 # to think about the best way of handling this and possibly consult
29 # upstream.
30 #
31 # Note that this particular find line is taken from the Debian packaging for
32 # gst-python1.0.
33 find "${D}" \
34 -name '*.pyc' -o \
35 -name '*.pyo' -o \
36 -name '*.la' -o \
37 -name 'libgstpythonplugin*' \
38 -delete
39}