summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-05-03 16:17:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-11 07:49:37 +0100
commit2856342f95ad1d2e9ebd220ec703560a2a683cfd (patch)
tree9f7dd3044bb164a4267986a7b7e177de61c32789 /meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb
parent03d219eebd5f6537486a94ab56be0aa3c9afc6b0 (diff)
downloadpoky-2856342f95ad1d2e9ebd220ec703560a2a683cfd.tar.gz
gst-python: upgrade 1.12.4 -> 1.14.0
For changes, please see: https://cgit.freedesktop.org/gstreamer/gst-python/tree/ChangeLog Also merge inc/bb since we have only one version now. (From OE-Core rev: 360493d4065101462194a49940e4024993011a79) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb
new file mode 100644
index 0000000000..1eb1a3f6f4
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "97782b2fde877f1d1d68c64f7db4f735"
10SRC_URI[sha256sum] = "e0b98111150aa3fcdeb6e228cd770995fbdaa8586fc02ec9b3273d4ae83399e6"
11
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
19inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection
20
21do_install_append() {
22 # gstpythonplugin hardcodes the location of the libpython from the build
23 # workspace and then fails at runtime. We can override it using
24 # --with-libpython-dir=${libdir}, but it still fails because it looks for a
25 # symlinked library ending in .so instead of the actually library with
26 # LIBNAME.so.MAJOR.MINOR. Although we could patch the code to use the path
27 # we want, it will break again if the library version ever changes. We need
28 # to think about the best way of handling this and possibly consult
29 # upstream.
30 #
31 # Note that this particular find line is taken from the Debian packaging for
32 # gst-python1.0.
33 find "${D}" \
34 -name '*.pyc' -o \
35 -name '*.pyo' -o \
36 -name '*.la' -o \
37 -name 'libgstpythonplugin*' \
38 -delete
39}