summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-05-09 12:01:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-11 07:49:37 +0100
commite7d761c8852d0cba6c177dca55ebe83d59d71db1 (patch)
treedb85458ee312c0b5f9b41bf0c0cdebd1d2104c32 /meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb
parent37e1470a9a40e3558c9df8012fd26dc4fe205920 (diff)
downloadpoky-e7d761c8852d0cba6c177dca55ebe83d59d71db1.tar.gz
gst-plugins-base: upgrade 1.12.4 -> 1.14.0
* For changes, please see: https://gstreamer.freedesktop.org/releases/1.14/ * OpenGL integration library has moved to -plugins-base, add PACKAGECONFIG. * Remove one patch as that has been fixed in a different way upstream. * Merge inc/bb and refresh patches to get rid of fuzz warnings. * Remove x86 specific cached variables as they're not needed anymore. * Add jpeg to PACKAGECONFIG and enable it by default. * Port gstreamer-gl specific patches from -plugins-bad. (From OE-Core rev: 5e95178996185976adf2f2d91550fa7ff0e82f54) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb
new file mode 100644
index 0000000000..08397a03a8
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.0.bb
@@ -0,0 +1,71 @@
1require gstreamer1.0-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
7
8SRC_URI = " \
9 http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
10 file://get-caps-from-src-pad-when-query-caps.patch \
11 file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \
12 file://make-gio_unix_2_0-dependency-configurable.patch \
13 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
14 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
15 file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
16 file://0003-riff-add-missing-include-directories-when-calling-in.patch \
17 file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
18 file://0009-glimagesink-Downrank-to-marginal.patch \
19 file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \
20 file://link-with-libvchostif.patch \
21 file://0001-gl-pick-up-GstVideo-1.0.gir-from-local-build-dir.patch \
22 "
23SRC_URI[md5sum] = "370271327dd23110421a9c2927ac989a"
24SRC_URI[sha256sum] = "7e904660ff56e02b036cf7fdfb77a50a540828ca9d2614d69ba931772e5b6940"
25
26S = "${WORKDIR}/gst-plugins-base-${PV}"
27
28DEPENDS += "iso-codes util-linux"
29
30inherit gettext
31
32PACKAGES_DYNAMIC =+ "^libgst.*"
33
34PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
35PACKAGECONFIG ??= " \
36 ${GSTREAMER_ORC} \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
38 gio-unix-2.0 ogg pango theora vorbis zlib jpeg \
39 ${PACKAGECONFIG_GL} \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
41"
42
43X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
44X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm"
45X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm"
46
47PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
48PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
49PACKAGECONFIG[gio-unix-2.0] = "--enable-gio_unix_2_0,--disable-gio_unix_2_0,glib-2.0"
50PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor"
51PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg"
52PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus"
53PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
54PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
55PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual"
56PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
57PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
58PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
59PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu"
60PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
61PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
62PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm"
63PACKAGECONFIG[jpeg] = ",,jpeg"
64
65FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
66
67do_compile_prepend() {
68 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/allocators/.libs"
69}
70
71FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h"