diff options
author | Jose Quaresma <quaresma.jose@gmail.com> | 2022-02-07 01:08:16 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-02-08 14:20:18 +0000 |
commit | 1197b1c5ed4077b8cc2fc8b24c8c9d2328e7e179 (patch) | |
tree | f427b445ac2089f8e4c744ac058892cdbfdd3d19 /meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.20.0.bb | |
parent | 7f4bd6e984fa8fec44490a88b104ca1c7334d1ae (diff) | |
download | poky-1197b1c5ed4077b8cc2fc8b24c8c9d2328e7e179.tar.gz |
gstreamer1.0-plugins-bad: upgrade 1.18.5 -> 1.20.0
- Remove meson options
libmms
ofa
- Add new meson options
gpl: Allow build plugins that have GPL-licensed dependencies
faad: Free AAC audio decoder plugin (GPL - only built if gpl option is also enabled!)
resindvd: Resin DVD playback plugin (GPL - only built if gpl option is also enabled!)
x265: HEVC/H.265 video encoder plugin (GPL - only built if gpl option is also enabled!)
- Add new meson options
Feature options for plugins without external deps
codecalpha
aes: AES encryption/decryption plugin
Feature options for plugins that need external deps
asio: Steinberg Audio Streaming Input Output (ASIO) plugin
gs: Google Cloud Storage source and sink plugin
ldac: LDAC bluetooth audio codec plugin
openaptx: Open Source implementation of Audio Processing Technology codec (aptX) plugin
qroverlay: new elements that allow overlaying data on top of video in the form of a QR code
onnx: ONNX neural network plugin
(From OE-Core rev: 76433d3628cbad311b428a57b25b4e2701ee513b)
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.20.0.bb')
-rw-r--r-- | meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.20.0.bb | 165 |
1 files changed, 165 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.20.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.20.0.bb new file mode 100644 index 0000000000..915d4ec744 --- /dev/null +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.20.0.bb | |||
@@ -0,0 +1,165 @@ | |||
1 | require gstreamer1.0-plugins-common.inc | ||
2 | |||
3 | DESCRIPTION = "'Bad' GStreamer plugins and helper libraries " | ||
4 | HOMEPAGE = "https://gstreamer.freedesktop.org/" | ||
5 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues" | ||
6 | |||
7 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \ | ||
8 | file://0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch \ | ||
9 | file://0002-avoid-including-sys-poll.h-directly.patch \ | ||
10 | file://0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch \ | ||
11 | file://0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ | ||
12 | file://0005-msdk-fix-includedir-path.patch \ | ||
13 | " | ||
14 | SRC_URI[sha256sum] = "015b8d4d9a395ebf444d40876867a2034dd3304b3ad48bc3a0dd0c1ee71dc11d" | ||
15 | |||
16 | S = "${WORKDIR}/gst-plugins-bad-${PV}" | ||
17 | |||
18 | LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+" | ||
19 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | ||
20 | |||
21 | DEPENDS += "gstreamer1.0-plugins-base" | ||
22 | |||
23 | inherit gobject-introspection | ||
24 | |||
25 | PACKAGECONFIG ??= " \ | ||
26 | ${GSTREAMER_ORC} \ | ||
27 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ | ||
28 | ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan x11', d)} \ | ||
29 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \ | ||
30 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \ | ||
31 | bz2 closedcaption curl dash dtls hls openssl sbc smoothstreaming \ | ||
32 | sndfile ttml uvch264 webp \ | ||
33 | ${@bb.utils.contains('TUNE_FEATURES', 'mx32', '', 'rsvg', d)} \ | ||
34 | " | ||
35 | |||
36 | PACKAGECONFIG[aom] = "-Daom=enabled,-Daom=disabled,aom" | ||
37 | PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass" | ||
38 | PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5" | ||
39 | PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2" | ||
40 | PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo" | ||
41 | PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl" | ||
42 | PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2" | ||
43 | PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394" | ||
44 | PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb" | ||
45 | PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl" | ||
46 | PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac" | ||
47 | PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth" | ||
48 | PACKAGECONFIG[hls] = "-Dhls=enabled,-Dhls=disabled," | ||
49 | # Pick atleast one crypto backend below when enabling hls | ||
50 | PACKAGECONFIG[nettle] = "-Dhls-crypto=nettle,,nettle" | ||
51 | PACKAGECONFIG[openssl] = "-Dhls-crypto=openssl,,openssl" | ||
52 | PACKAGECONFIG[gcrypt] = "-Dhls-crypto=libgcrypt,,libgcrypt" | ||
53 | # the gl packageconfig enables OpenGL elements that haven't been ported | ||
54 | # to -base yet. They depend on the gstgl library in -base, so we do | ||
55 | # not add GL dependencies here, since these are taken care of in -base. | ||
56 | PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled," | ||
57 | PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm" | ||
58 | PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265" | ||
59 | PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2" | ||
60 | PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms" | ||
61 | PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug" | ||
62 | PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk" | ||
63 | PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon" | ||
64 | PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft" | ||
65 | PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv" | ||
66 | PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264" | ||
67 | PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg" | ||
68 | PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt" | ||
69 | # the opus encoder/decoder elements are now in the -base package, | ||
70 | # but the opus parser remains in -bad | ||
71 | PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus" | ||
72 | PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg" | ||
73 | PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump" | ||
74 | PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc" | ||
75 | PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled" | ||
76 | PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2" | ||
77 | PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1" | ||
78 | PACKAGECONFIG[srt] = "-Dsrt=enabled,-Dsrt=disabled,srt" | ||
79 | PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp" | ||
80 | PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa" | ||
81 | PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo" | ||
82 | PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev" | ||
83 | PACKAGECONFIG[v4l2codecs] = "-Dv4l2codecs=enabled,-Dv4l2codecs=disabled,libgudev" | ||
84 | PACKAGECONFIG[va] = "-Dva=enabled,-Dva=disabled,libva" | ||
85 | PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc" | ||
86 | PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc" | ||
87 | PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader shaderc-native" | ||
88 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm" | ||
89 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp" | ||
90 | PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice" | ||
91 | PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing" | ||
92 | PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar" | ||
93 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,libxcb libxkbcommon" | ||
94 | |||
95 | # GPL - only built if gpl option is also enabled! | ||
96 | PACKAGECONFIG[gpl] = "-Dgpl=enabled,-Dgpl=disabled" | ||
97 | PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2" | ||
98 | PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav" | ||
99 | PACKAGECONFIG[x265] = "-Dx265=enabled,-Dx265=disabled,x265" | ||
100 | |||
101 | EXTRA_OEMESON += " \ | ||
102 | -Ddoc=disabled \ | ||
103 | -Daes=enabled \ | ||
104 | -Dcodecalpha=enabled \ | ||
105 | -Ddecklink=enabled \ | ||
106 | -Ddvb=enabled \ | ||
107 | -Dfbdev=enabled \ | ||
108 | -Dipcpipeline=enabled \ | ||
109 | -Dshm=enabled \ | ||
110 | -Dtranscode=enabled \ | ||
111 | -Dandroidmedia=disabled \ | ||
112 | -Dapplemedia=disabled \ | ||
113 | -Dasio=disabled \ | ||
114 | -Davtp=disabled \ | ||
115 | -Dbs2b=disabled \ | ||
116 | -Dchromaprint=disabled \ | ||
117 | -Dd3dvideosink=disabled \ | ||
118 | -Dd3d11=disabled \ | ||
119 | -Ddirectsound=disabled \ | ||
120 | -Ddts=disabled \ | ||
121 | -Dfdkaac=disabled \ | ||
122 | -Dflite=disabled \ | ||
123 | -Dgme=disabled \ | ||
124 | -Dgs=disabled \ | ||
125 | -Dgsm=disabled \ | ||
126 | -Diqa=disabled \ | ||
127 | -Dkate=disabled \ | ||
128 | -Dladspa=disabled \ | ||
129 | -Dldac=disabled \ | ||
130 | -Dlv2=disabled \ | ||
131 | -Dmagicleap=disabled \ | ||
132 | -Dmediafoundation=disabled \ | ||
133 | -Dmicrodns=disabled \ | ||
134 | -Dmpeg2enc=disabled \ | ||
135 | -Dmplex=disabled \ | ||
136 | -Dmusepack=disabled \ | ||
137 | -Dnvcodec=disabled \ | ||
138 | -Dopenexr=disabled \ | ||
139 | -Dopenni2=disabled \ | ||
140 | -Dopenaptx=disabled \ | ||
141 | -Dopensles=disabled \ | ||
142 | -Donnx=disabled \ | ||
143 | -Dqroverlay=disabled \ | ||
144 | -Dsoundtouch=disabled \ | ||
145 | -Dspandsp=disabled \ | ||
146 | -Dsvthevcenc=disabled \ | ||
147 | -Dteletext=disabled \ | ||
148 | -Dwasapi=disabled \ | ||
149 | -Dwasapi2=disabled \ | ||
150 | -Dwildmidi=disabled \ | ||
151 | -Dwinks=disabled \ | ||
152 | -Dwinscreencap=disabled \ | ||
153 | -Dwpe=disabled \ | ||
154 | -Dzxing=disabled \ | ||
155 | " | ||
156 | |||
157 | export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}" | ||
158 | |||
159 | ARM_INSTRUCTION_SET:armv4 = "arm" | ||
160 | ARM_INSTRUCTION_SET:armv5 = "arm" | ||
161 | |||
162 | FILES:${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs" | ||
163 | FILES:${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*" | ||
164 | FILES:${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles" | ||
165 | FILES:${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs" | ||