summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2020-10-25 14:23:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 17:23:20 +0000
commita85e744aa0f30eff79513a04559779f20b5a6715 (patch)
tree2a1f455124a037a5bb595a159986a26b43a50c24 /meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb
parent89bb085978eaa0cdda98da9e68dc46d6c3f59681 (diff)
downloadpoky-a85e744aa0f30eff79513a04559779f20b5a6715.tar.gz
gstreamer1.0-libav: Update 1.16.2 -> Update 1.16.3
(From OE-Core rev: cc27832fb7fb88ed9c97da742b54eaff760f0018) Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb
new file mode 100644
index 0000000000..98355a1b75
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.16.3.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Libav-based GStreamer 1.x plugin"
2HOMEPAGE = "http://gstreamer.freedesktop.org/"
3SECTION = "multimedia"
4
5LICENSE = "GPLv2+ & LGPLv2+ & ( (GPLv2+ & LGPLv2.1+) | (GPLv3+ & LGPLv3+) )"
6LICENSE_FLAGS = "commercial"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
9 file://ext/libav/gstav.h;beginline=1;endline=18;md5=a752c35267d8276fd9ca3db6994fca9c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${PV}.tar.xz \
12 "
13SRC_URI[md5sum] = "d08fb5429f102d5a3f1eca3dee2a0add"
14SRC_URI[sha256sum] = "d10c5eb1a00a91de97c85c0956c663aa6e99d268195cdec4534c179b831538ec"
15
16S = "${WORKDIR}/gst-libav-${PV}"
17
18DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base ffmpeg"
19
20inherit meson pkgconfig upstream-version-is-even
21
22FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
23FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
24
25delete_unused_libav_copy() {
26 # When building with meson, the internal libav copy is not used.
27 # It is only present for legacy autotools based builds. In future
28 # GStreamer versions, the autotools scripts will be gone, and so
29 # will this internal copy. Until then, it will be present. In order
30 # to make sure this copy is not included in the -src package, just
31 # manually delete the copy.
32 rm -rf "${S}/gst-libs/ext/libav/"
33}
34
35do_unpack[postfuncs] += " delete_unused_libav_copy"