summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
new file mode 100644
index 0000000000..495bb17649
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
@@ -0,0 +1,44 @@
1require gst-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \
6 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
7
8PR = "r8"
9
10PACKAGECONFIG ?= "jpeg \
11 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
13"
14PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
15PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
16PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
17PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
18PACKAGECONFIG[gdkpixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
19PACKAGECONFIG[v4l] = "--with-libv4l2,--without-libv4l2,libv4l"
20PACKAGECONFIG[bzip2] = "--enable-bz2,--disable-bz2,bzip2"
21PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
22PACKAGECONFIG[x11] = "--enable-x,--disable-x,virtual/libx11 libxfixes libxdamage"
23
24DEPENDS += "gst-plugins-base gconf cairo libpng zlib libid3tag flac \
25 speex libsoup-2.4 libcap"
26
27inherit gettext gconf
28
29SRC_URI += "file://0001-v4l2-fix-build-with-recent-kernels-the-v4l2_buffer-i.patch \
30 file://0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch \
31 file://0407-mulawdec-fix-integer-overrun.patch \
32"
33EXTRA_OECONF += "--disable-aalib --disable-esd --disable-shout2 --disable-libcaca --disable-hal \
34 --disable-examples --disable-taglib"
35
36do_configure_prepend() {
37 # This m4 file contains nastiness which conflicts with libtool 2.2.2
38 rm ${S}/m4/lib-link.m4 || true
39}
40
41SRC_URI[md5sum] = "24f98a294a2b521e1b29412bdadae2e6"
42SRC_URI[sha256sum] = "7e27840e40a7932ef2dc032d7201f9f41afcaf0b437daf5d1d44dc96d9e35ac6"
43
44FILES_${PN}-gconfelements += "${sysconfdir}/gconf/schemas/gstreamer-0.10.schemas"