summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-examples_git.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2018-01-04 15:12:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-05 12:02:37 +0000
commit6bcad1498937262df22077fbfc52c48e7a423459 (patch)
treee19fcd77453261b80c8c46b042b1ed74bdb817de /meta/recipes-multimedia/gstreamer/gst-examples_git.bb
parent651a82f26b6143af49ecf3e54671159fe15efe99 (diff)
downloadpoky-6bcad1498937262df22077fbfc52c48e7a423459.tar.gz
gst-player: Upgrade, rename to gst-examples
Switch to using current repository, switch to meson (following upstream), rename the recipe like upstream. Add a patch to install the player binaries. (From OE-Core rev: ac695195077dd12e41f6104e5cc77ec2cf03af11) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-examples_git.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-examples_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-examples_git.bb b/meta/recipes-multimedia/gstreamer/gst-examples_git.bb
new file mode 100644
index 0000000000..8891328b07
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-examples_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
2LICENSE = "LGPL-2.0+"
3LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
4
5DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 glib-2.0-native"
6
7SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-examples \
8 file://0001-Make-player-examples-installable.patch \
9 file://gst-player.desktop"
10
11SRCREV = "e88c04ff34cf56984e62a524a0bcc16ab51b282d"
12PV = "0.0.1+git${SRCPV}"
13UPSTREAM_CHECK_COMMITS = "1"
14
15S = "${WORKDIR}/git"
16
17inherit meson pkgconfig distro_features_check
18
19
20ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
21
22do_install_append() {
23 install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
24}
25
26RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback"
27RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \
28 gstreamer1.0-plugins-good-meta \
29 gstreamer1.0-plugins-bad-meta \
30 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
31 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
32RPROVIDES_${PN} += "gst-player gst-player-bin"