summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/flac/flac_1.2.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-multimedia/flac/flac_1.2.1.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-multimedia/flac/flac_1.2.1.bb')
-rw-r--r--meta/recipes-multimedia/flac/flac_1.2.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/flac/flac_1.2.1.bb b/meta/recipes-multimedia/flac/flac_1.2.1.bb
new file mode 100644
index 0000000000..30a8cfb933
--- /dev/null
+++ b/meta/recipes-multimedia/flac/flac_1.2.1.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "FLAC stands for Free Lossless Audio Codec, an audio format similar to MP3, but lossless."
2HOMEPAGE = "http://flac.sourceforge.net/"
3BUGTRACKER = "http://sourceforge.net/tracker/?group_id=13478&atid=113478"
4SECTION = "libs"
5LICENSE = "FDLv1.2 & GPLv2+ & LGPLv2.1+ & BSD"
6LIC_FILES_CHKSUM = "file://COPYING.FDL;md5=ad1419ecc56e060eccf8184a87c4285f \
7 file://src/Makefile.am;beginline=1;endline=16;md5=8dee151a56a3122f064a9dce771db37d \
8 file://COPYING.GPL;md5=079b27cd65c86dbc1b6997ffde902735 \
9 file://src/flac/main.c;beginline=1;endline=17;md5=756c4234516e4266ea45ee7bbbd798cf \
10 file://COPYING.LGPL;md5=fbc093901857fcd118f065f900982c24 \
11 file://src/plugin_common/all.h;beginline=1;endline=17;md5=b2e7960da6b43e4eccabf999bcf7f3a9 \
12 file://COPYING.Xiph;md5=df8975c0225f83ed7b567587ed953b83 \
13 file://include/FLAC/all.h;beginline=64;endline=69;md5=64474f2b22e9e77b28d8b8b25c983a48"
14DEPENDS = "libogg"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
19 file://disable-xmms-plugin.patch;patch=1 \
20 file://flac-gcc43-fixes.patch;patch=1 \
21 file://xmms.m4"
22
23S = "${WORKDIR}/flac-${PV}"
24
25inherit autotools
26
27EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
28 --with-ogg-libraries=${STAGING_LIBDIR} \
29 --with-ogg-includes=${STAGING_INCDIR} \
30 --without-xmms-prefix \
31 --without-xmms-exec-prefix \
32 --without-libiconv-prefix \
33 --without-id3lib"
34
35PACKAGES += "libflac libflac++ liboggflac liboggflac++"
36FILES_${PN} = "${bindir}/*"
37FILES_libflac = "${libdir}/libFLAC.so.*"
38FILES_libflac++ = "${libdir}/libFLAC++.so.*"
39FILES_liboggflac = "${libdir}/libOggFLAC.so.*"
40FILES_liboggflac++ = "${libdir}/libOggFLAC++.so.*"
41
42do_configure () {
43 install -d ${S}/m4
44 install -m 0644 ${WORKDIR}/xmms.m4 ${S}/m4/
45 autotools_do_configure
46 # removes '-read-only-relocs' which is enabled for PowerPC builds.
47 # It makes the build fail, other archs are not affected. Fixes #1775.
48 sed -i 's/-Wl,-read_only_relocs,warning//g' src/libFLAC/Makefile
49}