diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-multimedia/alsa/alsa-utils_1.0.23.bb | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-utils_1.0.23.bb')
-rw-r--r-- | meta/recipes-multimedia/alsa/alsa-utils_1.0.23.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-utils_1.0.23.bb b/meta/recipes-multimedia/alsa/alsa-utils_1.0.23.bb new file mode 100644 index 0000000000..7b30c0d4b0 --- /dev/null +++ b/meta/recipes-multimedia/alsa/alsa-utils_1.0.23.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | DESCRIPTION = "ALSA Utilities" | ||
2 | HOMEPAGE = "http://www.alsa-project.org" | ||
3 | BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \ | ||
7 | file://alsactl/utils.c;beginline=1;endline=20;md5=fe9526b055e246b5558809a5ae25c0b9" | ||
8 | DEPENDS = "alsa-lib ncurses gettext" | ||
9 | PR = "r0" | ||
10 | |||
11 | SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \ | ||
12 | file://ncursesfix.patch;patch=1 " | ||
13 | |||
14 | # lazy hack. needs proper fixing in gettext.m4, see | ||
15 | # http://bugs.openembedded.org/show_bug.cgi?id=2348 | ||
16 | # please close bug and remove this comment when properly fixed | ||
17 | # | ||
18 | EXTRA_OECONF = "--disable-xmlto" | ||
19 | EXTRA_OECONF_linux-uclibc = "--disable-nls" | ||
20 | EXTRA_OECONF_linux-uclibcgnueabi = "--disable-nls" | ||
21 | |||
22 | inherit autotools | ||
23 | |||
24 | # This are all packages that we need to make. Also, the now empty alsa-utils | ||
25 | # ipk depend on them. | ||
26 | |||
27 | PACKAGES += "\ | ||
28 | alsa-utils-alsamixer \ | ||
29 | alsa-utils-midi \ | ||
30 | alsa-utils-aplay \ | ||
31 | alsa-utils-amixer \ | ||
32 | alsa-utils-aconnect \ | ||
33 | alsa-utils-iecset \ | ||
34 | alsa-utils-speakertest \ | ||
35 | alsa-utils-aseqnet \ | ||
36 | alsa-utils-aseqdump \ | ||
37 | alsa-utils-alsaconf \ | ||
38 | alsa-utils-alsactl " | ||
39 | |||
40 | # We omit alsaconf, because | ||
41 | # a) this is a bash script | ||
42 | # b) it creates config files not suitable for OE-based distros | ||
43 | |||
44 | FILES_${PN} = "" | ||
45 | FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord" | ||
46 | FILES_alsa-utils-amixer = "${bindir}/amixer" | ||
47 | FILES_alsa-utils-alsamixer = "${bindir}/alsamixer" | ||
48 | FILES_alsa-utils-speakertest = "${bindir}/speaker-test ${datadir}/sounds/alsa/ ${datadir}/alsa/" | ||
49 | FILES_alsa-utils-midi = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bindir}/amidi" | ||
50 | FILES_alsa-utils-aconnect = "${bindir}/aconnect" | ||
51 | FILES_alsa-utils-aseqnet = "${bindir}/aseqnet" | ||
52 | FILES_alsa-utils-iecset = "${bindir}/iecset" | ||
53 | FILES_alsa-utils-alsactl = "${sbindir}/alsactl" | ||
54 | FILES_alsa-utils-aseqdump = "${bindir}/aseqdump" | ||
55 | FILES_alsa-utils-alsaconf = "${sbindir}/alsaconf" | ||
56 | |||
57 | DESCRIPTION_alsa-utils-aplay = "play (and record) sound files via ALSA" | ||
58 | DESCRIPTION_alsa-utils-amixer = "command-line based control for ALSA mixer and settings" | ||
59 | DESCRIPTION_alsa-utils-alsamixer = "ncurses based control for ALSA mixer and settings" | ||
60 | DESCRIPTION_alsa-utils-speakertest = "ALSA surround speaker test utility" | ||
61 | DESCRIPTION_alsa-utils-midi = "miscalleanous MIDI utilities for ALSA" | ||
62 | DESCRIPTION_alsa-utils-aconnect = "ALSA sequencer connection manager" | ||
63 | DESCRIPTION_alsa-utils-aseqnet = "network client/server on ALSA sequencer" | ||
64 | DESCRIPTION_alsa-utils-alsactl = "saves/restores ALSA-settings in /etc/asound.state" | ||
65 | DESCRIPTION_alsa-utils-alsaconf = "a bash script that creates ALSA configuration files" | ||
66 | |||
67 | ALLOW_EMPTY_alsa-utils = "1" | ||