summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2017-11-27 18:39:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-10 22:45:18 +0000
commitea36a9a9622dca337696999f2c643095b130b2b0 (patch)
tree3b4280fea34682c18f85b2e9fcb2f71f9cc11672 /meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb
parentb497f42eadb6bfd2564f969e2faf6c4b007ca2a9 (diff)
downloadpoky-ea36a9a9622dca337696999f2c643095b130b2b0.tar.gz
alsa-tools: 1.1.3 -> 1.1.5
Changes: http://www.alsa-project.org/main/index.php/Changes_v1.1.4_v1.1.5 Rebased autotools.patch and makefile_no_gtk.patch. Dropped 0001-as10k1-Make-output_tram_line-static-inline.patch with the assumption that it's not needed any more. The patch added a "static" qualifier to a function. According to the commit message, this was done to improve optimization. Upstream removed the "inline" qualifier from that same function, because it caused some trouble with clang. My guess is that the patch author actually ran into the same clang problem as upstream, but came up with a different fix. It doesn't seem like a function whose optimization anyone would really be interested in. Cc: Khem Raj <raj.khem@gmail.com> (From OE-Core rev: 569beb5f5e32536a3b2e398ddc218ce5ad76cbe1) Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb
new file mode 100644
index 0000000000..1be43aa6e7
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.1.5.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Advanced tools for certain ALSA sound card drivers"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & LGPLv2+"
6DEPENDS = "alsa-lib ncurses glib-2.0"
7
8LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
9 file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/${BP}.tar.bz2 \
12 file://autotools.patch \
13 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'file://makefile_no_gtk.patch', d)} \
14 file://gitcompile_hdajacksensetest \
15 "
16
17SRC_URI[md5sum] = "3afb92eb1b4f2edc8691498e57c3ec78"
18SRC_URI[sha256sum] = "bc3c6567de835223ee7d69487b8c22fb395a2e8c613341b0c96e6a5f6a2bd534"
19
20inherit autotools-brokensep pkgconfig
21
22CLEANBROKEN = "1"
23
24EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'"
25
26PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
27PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3,"
28
29# configure.ac/.in doesn't exist so force copy
30AUTOTOOLS_COPYACLOCAL = "1"
31
32do_compile_prepend () {
33 #Automake dir is not correctly detected in cross compilation case
34 export AUTOMAKE_DIR="$(automake --print-libdir)"
35 export ACLOCAL_FLAGS="--system-acdir=${ACLOCALDIR}/ ${ACLOCALEXTRAPATH}"
36
37 cp ${WORKDIR}/gitcompile_hdajacksensetest ${S}/hdajacksensetest/gitcompile
38}
39
40FILES_${PN} += "${datadir}/ld10k1"