diff options
author | Tanu Kaskinen <tanuk@iki.fi> | 2017-11-27 18:39:32 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-12-10 22:45:18 +0000 |
commit | b497f42eadb6bfd2564f969e2faf6c4b007ca2a9 (patch) | |
tree | 6cc11195ff7e0bf95a016426cacb0f400764e874 /meta/recipes-multimedia/alsa/alsa-plugins_1.1.5.bb | |
parent | e22a9a3409a2031b39d7a3eb3eccf9561c1669be (diff) | |
download | poky-b497f42eadb6bfd2564f969e2faf6c4b007ca2a9.tar.gz |
alsa-plugins: 1.1.4 -> 1.1.5
Changes:
http://www.alsa-project.org/main/index.php/Changes_v1.1.4_v1.1.5
(From OE-Core rev: a0ae70f9470dfeef8f2073168e16a6b67f7d2fad)
Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-plugins_1.1.5.bb')
-rw-r--r-- | meta/recipes-multimedia/alsa/alsa-plugins_1.1.5.bb | 103 |
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-plugins_1.1.5.bb b/meta/recipes-multimedia/alsa/alsa-plugins_1.1.5.bb new file mode 100644 index 0000000000..4bd0acc54f --- /dev/null +++ b/meta/recipes-multimedia/alsa/alsa-plugins_1.1.5.bb | |||
@@ -0,0 +1,103 @@ | |||
1 | SUMMARY = "ALSA Plugins" | ||
2 | HOMEPAGE = "http://alsa-project.org" | ||
3 | BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking" | ||
4 | SECTION = "multimedia" | ||
5 | |||
6 | # The primary license of alsa-plugins is LGPLv2.1. | ||
7 | # | ||
8 | # m4/attributes.m4 is licensed under GPLv2+. m4/attributes.m4 is part of the | ||
9 | # build system, and doesn't affect the licensing of the build result. | ||
10 | # | ||
11 | # The samplerate plugin source code is licensed under GPLv2+ to be consistent | ||
12 | # with the libsamplerate license. However, if the licensee has a commercial | ||
13 | # license for libsamplerate, the samplerate plugin may be used under the terms | ||
14 | # of LGPLv2.1 like the rest of the plugins. | ||
15 | LICENSE = "LGPLv2.1 & GPLv2+" | ||
16 | LIC_FILES_CHKSUM = "\ | ||
17 | file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \ | ||
18 | file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
19 | file://m4/attributes.m4;endline=33;md5=b25958da44c02231e3641f1bccef53eb \ | ||
20 | file://rate/rate_samplerate.c;endline=35;md5=fd77bce85f4a338c0e8ab18430b69fae \ | ||
21 | " | ||
22 | |||
23 | SRC_URI = "ftp://ftp.alsa-project.org/pub/plugins/${BP}.tar.bz2" | ||
24 | SRC_URI[md5sum] = "f898b0e6e8acf3f6f82bc2a0f0c84a97" | ||
25 | SRC_URI[sha256sum] = "797da5f8f53379fbea28817bc466de16affd2c07849e84f1af8d5e22f7bb7f1c" | ||
26 | |||
27 | DEPENDS += "alsa-lib" | ||
28 | |||
29 | inherit autotools pkgconfig | ||
30 | |||
31 | PACKAGECONFIG ??= "\ | ||
32 | samplerate \ | ||
33 | speexdsp \ | ||
34 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)} \ | ||
35 | " | ||
36 | PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec,libav" | ||
37 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" | ||
38 | PACKAGECONFIG[maemo-plugin] = "--enable-maemo-plugin,--disable-maemo-plugin" | ||
39 | PACKAGECONFIG[maemo-resource-manager] = "--enable-maemo-resource-manager,--disable-maemo-resource-manager,dbus" | ||
40 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" | ||
41 | PACKAGECONFIG[samplerate] = "--enable-samplerate,--disable-samplerate,libsamplerate0" | ||
42 | PACKAGECONFIG[speexdsp] = "--with-speex=lib,--with-speex=no,speexdsp" | ||
43 | |||
44 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'alsa-plugins-pulseaudio-conf', '', d)}" | ||
45 | |||
46 | PACKAGES_DYNAMIC = "^libasound-module-.*" | ||
47 | |||
48 | # The alsa-plugins package doesn't itself contain anything, it just depends on | ||
49 | # all built plugins. | ||
50 | ALLOW_EMPTY_${PN} = "1" | ||
51 | |||
52 | do_install_append() { | ||
53 | rm ${D}${libdir}/alsa-lib/*.la | ||
54 | |||
55 | # We use the example as is, so just drop the .example suffix. | ||
56 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'yes', 'no', d)}" = "yes" ]; then | ||
57 | mv ${D}${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf.example ${D}${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | python populate_packages_prepend() { | ||
62 | plugindir = d.expand('${libdir}/alsa-lib/') | ||
63 | packages = " ".join(do_split_packages(d, plugindir, '^libasound_module_(.*)\.so$', 'libasound-module-%s', 'Alsa plugin for %s', extra_depends='')) | ||
64 | d.setVar("RDEPENDS_alsa-plugins", packages) | ||
65 | } | ||
66 | |||
67 | # The rate plugins create some symlinks. For example, the samplerate plugin | ||
68 | # creates these links to the main plugin file: | ||
69 | # | ||
70 | # libasound_module_rate_samplerate_best.so | ||
71 | # libasound_module_rate_samplerate_linear.so | ||
72 | # libasound_module_rate_samplerate_medium.so | ||
73 | # libasound_module_rate_samplerate_order.so | ||
74 | # | ||
75 | # The other rate plugins create similar links. We have to add the links to | ||
76 | # FILES manually, because do_split_packages() skips the links (which is good, | ||
77 | # because we wouldn't want do_split_packages() to create separate packages for | ||
78 | # the symlinks). | ||
79 | # | ||
80 | # The symlinks cause QA errors, because usually it's a bug if a non | ||
81 | # -dev/-dbg/-nativesdk package contains links to .so files, but in this case | ||
82 | # the errors are false positives, so we disable the QA checks. | ||
83 | FILES_${MLPREFIX}libasound-module-rate-lavcrate += "${libdir}/alsa-lib/*rate_lavcrate_*.so" | ||
84 | FILES_${MLPREFIX}libasound-module-rate-samplerate += "${libdir}/alsa-lib/*rate_samplerate_*.so" | ||
85 | FILES_${MLPREFIX}libasound-module-rate-speexrate += "${libdir}/alsa-lib/*rate_speexrate_*.so" | ||
86 | INSANE_SKIP_${MLPREFIX}libasound-module-rate-lavcrate = "dev-so" | ||
87 | INSANE_SKIP_${MLPREFIX}libasound-module-rate-samplerate = "dev-so" | ||
88 | INSANE_SKIP_${MLPREFIX}libasound-module-rate-speexrate = "dev-so" | ||
89 | |||
90 | # 50-pulseaudio.conf defines a device named "pulse" that applications can use | ||
91 | # if they explicitly want to use the PulseAudio plugin. | ||
92 | # 99-pulseaudio-default.conf configures the "default" device to use the | ||
93 | # PulseAudio plugin. | ||
94 | FILES_${PN}-pulseaudio-conf += "\ | ||
95 | ${datadir}/alsa/alsa.conf.d/50-pulseaudio.conf \ | ||
96 | ${datadir}/alsa/alsa.conf.d/99-pulseaudio-default.conf \ | ||
97 | " | ||
98 | |||
99 | RDEPENDS_${PN}-pulseaudio-conf += "\ | ||
100 | libasound-module-conf-pulse \ | ||
101 | libasound-module-ctl-pulse \ | ||
102 | libasound-module-pcm-pulse \ | ||
103 | " | ||