summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2019-02-21 22:13:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 10:43:06 +0000
commit51254af4b052464fa0cfb94d8b3d02025ca063dc (patch)
treef47e8e5fd4ed7f818f3efed9d75de2b93f6f00f4 /meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
parentc8a212a65e5bcb0dfb427ad6d531c6e7ee39b4d6 (diff)
downloadpoky-51254af4b052464fa0cfb94d8b3d02025ca063dc.tar.gz
alsa-lib: 1.1.6 -> 1.1.8
Changelogs: http://alsa-project.org/main/index.php/Changes_v1.1.6_v1.1.7 http://alsa-project.org/main/index.php/Changes_v1.1.7_v1.1.8 One significant change was that the search path of add-on configuration files was changed from /usr/share/alsa/alsa.conf.d to /etc/alsa/conf.d. Packages that install such files should still use the /usr/share location, though. Symlinks need to be created from /etc to /usr/share. The rationale for using /etc is that the system administrator can better control the configuration that way, and the rationale for installing files under /usr/share is that configuration snippets that are installed by packages are not meant to be directly edited by the administrator. alsa-plugins had to be modified to add symlinks for the configuration snippets that it installs. I also added FILES_${PN} = "", because the alsa-plugins package is supposed to be empty, but also because for some reason that I don't understand the symlinks would otherwise go to the alsa-plugins package rather than alsa-plugins-pulseaudio-conf. SRC_URI was changed to a more reliable source (at least currently the ftp server is flaky). (From OE-Core rev: 91f506958e4b7e9b8e8f1dcfe4a8aa4bdac7c5d1) Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
new file mode 100644
index 0000000000..76cc9627e5
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.1.8.bb
@@ -0,0 +1,41 @@
1SUMMARY = "ALSA sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
7 file://src/socket.c;md5=dd1bc7f44872690224d89c1a9806e495;beginline=1;endline=26 \
8 "
9
10SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2"
11SRC_URI[md5sum] = "0eec0d657a07927795809c8f87fb76ca"
12SRC_URI[sha256sum] = "3cdc3a93a6427a26d8efab4ada2152e64dd89140d981f6ffa003e85be707aedf"
13
14inherit autotools pkgconfig
15
16EXTRA_OECONF += " \
17 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-softfloat', '', d)} \
18 --disable-python \
19"
20
21PACKAGES =+ "alsa-server alsa-conf alsa-doc"
22
23FILES_alsa-server = "${bindir}/*"
24FILES_alsa-conf = "${datadir}/alsa/"
25
26RDEPENDS_${PN}_class-target = "alsa-conf"
27
28# upgrade path
29RPROVIDES_${PN} = "libasound"
30RREPLACES_${PN} = "libasound"
31RCONFLICTS_${PN} = "libasound"
32
33RPROVIDES_${PN}-dev = "alsa-dev"
34RREPLACES_${PN}-dev = "alsa-dev"
35RCONFLICTS_${PN}-dev = "alsa-dev"
36
37RPROVIDES_alsa-conf = "alsa-conf-base"
38RREPLACES_alsa-conf = "alsa-conf-base"
39RCONFLICTS_alsa-conf = "alsa-conf-base"
40
41BBCLASSEXTEND = "native nativesdk"