summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2017-11-27 18:39:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-10 22:45:18 +0000
commite22a9a3409a2031b39d7a3eb3eccf9561c1669be (patch)
treecbf78874f0680a195bb520f19f12cd06487097ae /meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
parente310fbff97490615f8ab46dd8029092abe461616 (diff)
downloadpoky-e22a9a3409a2031b39d7a3eb3eccf9561c1669be.tar.gz
alsa-lib: 1.1.4.1 -> 1.1.5
Changes: http://www.alsa-project.org/main/index.php/Changes_v1.1.4_v1.1.5 Dropped all patches. The poll.h patch is included in the release, and the wordexp patch is not needed any more, because the wordexp function is replaced by an internal reimplementation. It would still be possible to enable the use of wordexp with the --with-wordexp configure option. The option exists, because the internal reimplementation covers only part of what wordexp can do, so not using wordexp can in theory cause regressions. However, it seems that regressions are quite unlikely in practice. Here's some discussion about the topic: http://mailman.alsa-project.org/pipermail/alsa-devel/2017-July/122667.html (From OE-Core rev: 00b73cbe8ae6d1dd6ba82f0ab5cd38c2d712deb7) Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
new file mode 100644
index 0000000000..c5bf107e5e
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
@@ -0,0 +1,40 @@
1SUMMARY = "ALSA sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
7 file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
8
9BBCLASSEXTEND = "native nativesdk"
10
11SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2"
12SRC_URI[md5sum] = "a2b465c3a5265d8a57f3ff39c6c4fc29"
13SRC_URI[sha256sum] = "f4f68ad3c6da36b0b5241ac3c798a7a71e0e97d51f972e9f723b3f20a9650ae6"
14
15inherit autotools pkgconfig
16
17require alsa-fpu.inc
18EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
19
20EXTRA_OECONF += "--disable-python"
21
22PACKAGES =+ "alsa-server libasound alsa-conf alsa-doc"
23FILES_libasound = "${libdir}/libasound.so.*"
24FILES_alsa-server = "${bindir}/*"
25FILES_alsa-conf = "${datadir}/alsa/"
26
27RDEPENDS_libasound = "alsa-conf"
28
29# alsa-lib gets automatically added to alsa-lib-dev dependencies, but the
30# alsa-lib package doesn't exist. libasound is the real library package.
31RDEPENDS_${PN}-dev = "libasound"
32
33# upgrade path
34RPROVIDES_${PN}-dev = "alsa-dev"
35RREPLACES_${PN}-dev = "alsa-dev"
36RCONFLICTS_${PN}-dev = "alsa-dev"
37
38RPROVIDES_alsa-conf = "alsa-conf-base"
39RREPLACES_alsa-conf = "alsa-conf-base"
40RCONFLICTS_alsa-conf = "alsa-conf-base"