summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2016-01-14 14:41:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-18 11:47:05 +0000
commit180f17049ea3e8da75c384d3c1e2f9a7ee06f181 (patch)
tree72f128a27b519df88187a7d214438b8c3be8a3da /meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb
parenta8c25af91e56f20b9cfd4fa298b5002efc7af809 (diff)
downloadpoky-180f17049ea3e8da75c384d3c1e2f9a7ee06f181.tar.gz
alsa-lib: 1.0.29 -> 1.1.0
Changelog: http://alsa-project.org/main/index.php/Changes_v1.0.29_v1.1.0 The most significant change is probably the addition of the "topology API", which is used to change the DSP topology from userspace. My understanding is that the API is (or will be) needed to support some new hardware, but I don't know any specifics about that. Rebased Check-if-wordexp-function-is-supported.patch. Dropped 0001-build-Do-not-try-to-detect-cross-compiler.patch, since it is included in the new release. (From OE-Core rev: 13a2786493bd91a54e3a5342da11c06a9b6c99b8) Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb
new file mode 100644
index 0000000000..d62c1fc31c
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.1.0.bb
@@ -0,0 +1,49 @@
1SUMMARY = "ALSA sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
7 file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
8
9BBCLASSEXTEND = "native nativesdk"
10
11# configure.in sets -D__arm__ on the command line for any arm system
12# (not just those with the ARM instruction set), this should be removed,
13# (or replaced by a permitted #define).
14#FIXME: remove the following
15ARM_INSTRUCTION_SET = "arm"
16
17SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2 \
18 file://Check-if-wordexp-function-is-supported.patch \
19"
20SRC_URI[md5sum] = "69515ca73c3c4a212ef45160dea846c1"
21SRC_URI[sha256sum] = "dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15"
22
23inherit autotools pkgconfig
24
25require alsa-fpu.inc
26EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
27
28EXTRA_OECONF = "--disable-python"
29
30EXTRA_OECONF_append_libc-uclibc = " --with-versioned=no "
31
32PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc"
33FILES_${PN} += "${libdir}/${BPN}/smixer/*.so"
34FILES_${PN}-dev += "${libdir}/${BPN}/smixer/*.la"
35FILES_libasound = "${libdir}/libasound.so.*"
36FILES_alsa-server = "${bindir}/*"
37FILES_alsa-conf = "${datadir}/alsa/"
38FILES_alsa-conf-base = "\
39${datadir}/alsa/alsa.conf \
40${datadir}/alsa/cards/aliases.conf \
41${datadir}/alsa/pcm/default.conf \
42${datadir}/alsa/pcm/dmix.conf \
43${datadir}/alsa/pcm/dsnoop.conf"
44
45RDEPENDS_libasound = "alsa-conf-base alsa-conf"
46# upgrade path
47RPROVIDES_${PN}-dev = "alsa-dev"
48RREPLACES_${PN}-dev = "alsa-dev"
49RCONFLICTS_${PN}-dev = "alsa-dev"