summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-04-20 22:45:43 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-24 11:06:54 +0100
commit775dedb67ed85ee99c8e818ced0939c5605d5a0c (patch)
treeacdf82b197d2d125021637bc05e5e2a2d9781676 /meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
parentb80a8feb714908fa0ef1a0472d16e9e1e77e269d (diff)
downloadpoky-775dedb67ed85ee99c8e818ced0939c5605d5a0c.tar.gz
alsa-lib: 1.0.28 -> 1.0.29
Release notes: http://alsa-project.org/main/index.php/Changes_v1.0.28_v1.0.29 Dropped the backported patches. Dropped also fix-tstamp-declaration.patch. It's unclear whether the ancient patch is needed by anyone any more. The original commit message[1] wasn't very clear on what specific conditions triggered the build failure that the patch fixes, so it's hard to try to reproduce the failure. [1] http://cgit.openembedded.org/openembedded/commit/?id=f61f3efe2389249c001107ccd55dac39e79ef2a1 (From OE-Core rev: 893b317c354d2bb4ee9f44d7318e0f59382060a9) Signed-off-by: Tanu Kaskinen <tanu.kaskinen@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
new file mode 100644
index 0000000000..fc6ba693f5
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
@@ -0,0 +1,50 @@
1SUMMARY = "ALSA sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
7 file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
8
9BBCLASSEXTEND = "native nativesdk"
10
11# configure.in sets -D__arm__ on the command line for any arm system
12# (not just those with the ARM instruction set), this should be removed,
13# (or replaced by a permitted #define).
14#FIXME: remove the following
15ARM_INSTRUCTION_SET = "arm"
16
17SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2 \
18 file://Check-if-wordexp-function-is-supported.patch \
19"
20SRC_URI[md5sum] = "de67e0eca72474d6b1121037dafe1024"
21SRC_URI[sha256sum] = "73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0"
22
23inherit autotools pkgconfig
24
25require alsa-fpu.inc
26EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
27
28EXTRA_OECONF = "--disable-python"
29
30EXTRA_OECONF_append_libc-uclibc = " --with-versioned=no "
31
32PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc"
33FILES_${PN} += "${libdir}/${BPN}/smixer/*.so"
34FILES_${PN}-dbg += "${libdir}/${BPN}/smixer/.debug"
35FILES_${PN}-dev += "${libdir}/${BPN}/smixer/*.la"
36FILES_libasound = "${libdir}/libasound.so.*"
37FILES_alsa-server = "${bindir}/*"
38FILES_alsa-conf = "${datadir}/alsa/"
39FILES_alsa-conf-base = "\
40${datadir}/alsa/alsa.conf \
41${datadir}/alsa/cards/aliases.conf \
42${datadir}/alsa/pcm/default.conf \
43${datadir}/alsa/pcm/dmix.conf \
44${datadir}/alsa/pcm/dsnoop.conf"
45
46RDEPENDS_libasound = "alsa-conf-base alsa-conf"
47# upgrade path
48RPROVIDES_${PN}-dev = "alsa-dev"
49RREPLACES_${PN}-dev = "alsa-dev"
50RCONFLICTS_${PN}-dev = "alsa-dev"