summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2013-07-31 17:49:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-03 10:33:09 +0100
commit6d5d0c41a7cc52e429bfd69ea0ec9215f8150b51 (patch)
treeaa574090b578c15e30bc73b6a7c6622d9257edf5 /meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb
parent8d68f1695c7a57bb5b3d5635a48cf2987d589cd3 (diff)
downloadpoky-6d5d0c41a7cc52e429bfd69ea0ec9215f8150b51.tar.gz
alsa-lib: upgrade to v1.0.27.2
fix-O0-Optimize-unable-inline-function.patch, obsolete_automake_macros.patch patches included in upstream; removed. unbreak_plugindir.patch not used, removed. (From OE-Core rev: d438c87012a03bf556fe306b178a68ff41d19bc0) Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb
new file mode 100644
index 0000000000..545594466c
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.27.2.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "ALSA sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
7 file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
8
9BBCLASSEXTEND = "native nativesdk"
10
11# configure.in sets -D__arm__ on the command line for any arm system
12# (not just those with the ARM instruction set), this should be removed,
13# (or replaced by a permitted #define).
14#FIXME: remove the following
15ARM_INSTRUCTION_SET = "arm"
16
17SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
18 file://Check-if-wordexp-function-is-supported.patch \
19 file://fix-tstamp-declaration.patch \
20 "
21SRC_URI[md5sum] = "69129a7c37697f81ac092335e9fa452b"
22SRC_URI[sha256sum] = "690ed393e7efd4fc7e3a2d2cda5449298ca0c895197e5914e350882012430d19"
23
24inherit autotools pkgconfig
25
26require alsa-fpu.inc
27EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
28
29EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
30
31EXTRA_OECONF_append_libc-uclibc = " --with-versioned=no "
32
33PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
34FILES_${PN} += "${libdir}/${BPN}/smixer/*.so"
35FILES_${PN}-dbg += "${libdir}/${BPN}/smixer/.debug"
36FILES_${PN}-dev += "${libdir}/${BPN}/smixer/*.la"
37FILES_libasound = "${libdir}/libasound.so.*"
38FILES_alsa-server = "${bindir}/*"
39FILES_alsa-conf = "${datadir}/alsa/"
40FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
41FILES_alsa-conf-base = "\
42${datadir}/alsa/alsa.conf \
43${datadir}/alsa/cards/aliases.conf \
44${datadir}/alsa/pcm/default.conf \
45${datadir}/alsa/pcm/dmix.conf \
46${datadir}/alsa/pcm/dsnoop.conf"
47
48RDEPENDS_libasound = "alsa-conf-base"