diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb')
-rw-r--r-- | meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb new file mode 100644 index 0000000000..b0a2a305c0 --- /dev/null +++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "Alsa sound library" | ||
2 | HOMEPAGE = "http://www.alsa-project.org" | ||
3 | BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php" | ||
4 | SECTION = "libs/multimedia" | ||
5 | LICENSE = "LGPLv2.1 & GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \ | ||
7 | file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545" | ||
8 | |||
9 | # configure.in sets -D__arm__ on the command line for any arm system | ||
10 | # (not just those with the ARM instruction set), this should be removed, | ||
11 | # (or replaced by a permitted #define). | ||
12 | #FIXME: remove the following | ||
13 | ARM_INSTRUCTION_SET = "arm" | ||
14 | |||
15 | PR = "r0" | ||
16 | |||
17 | SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \ | ||
18 | file://fix-tstamp-declaration.patch;patch=1" | ||
19 | |||
20 | inherit autotools pkgconfig | ||
21 | |||
22 | require alsa-fpu.inc | ||
23 | EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} " | ||
24 | |||
25 | EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python" | ||
26 | |||
27 | PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev" | ||
28 | FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*" | ||
29 | FILES_libasound = "${libdir}/libasound.so.*" | ||
30 | FILES_alsa-server = "${bindir}/*" | ||
31 | FILES_alsa-conf = "${datadir}/alsa/" | ||
32 | FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*" | ||
33 | FILES_alsa-conf-base = "\ | ||
34 | ${datadir}/alsa/alsa.conf \ | ||
35 | ${datadir}/alsa/cards/aliases.conf \ | ||
36 | ${datadir}/alsa/pcm/default.conf \ | ||
37 | ${datadir}/alsa/pcm/dmix.conf \ | ||
38 | ${datadir}/alsa/pcm/dsnoop.conf" | ||
39 | |||
40 | RDEPENDS_libasound = "alsa-conf-base" | ||