summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-07-20 17:13:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-26 13:16:40 +0100
commit077ad469349734fe82f4cc920ed8375f5282d9dc (patch)
tree5692c3fe31261aa958f908849999f5f7397d00cd /meta/recipes-kernel/systemtap/systemtap_git.bb
parentb7b203d8ea30056b5e03e7ef04504e5d5bee1a1a (diff)
downloadpoky-077ad469349734fe82f4cc920ed8375f5282d9dc.tar.gz
systemtap: improve reproducibility
- Fix build path issue of .pyc files: Supply "--root" directory to the "install" command. - Fix build path issue of c++ object files: Use relative dir to include header string_ref. - Fix build path issue of c library generated by distutils: Add OE's CFLAGS which contains `-fdebug-prefix-map' options to setup.py [YOCTO #12528] (From OE-Core rev: 806a8626c3fb5020666152b295f12541f5f61ffd) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index b280f583e2..0b7833e901 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -3,6 +3,8 @@ HOMEPAGE = "https://sourceware.org/systemtap/"
3 3
4require systemtap_git.inc 4require systemtap_git.inc
5 5
6SRC_URI += "file://0001-improve-reproducibility-for-c-compiling.patch"
7
6DEPENDS = "elfutils" 8DEPENDS = "elfutils"
7 9
8EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \ 10EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
@@ -25,6 +27,12 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
25 27
26inherit autotools gettext pkgconfig distutils3-base 28inherit autotools gettext pkgconfig distutils3-base
27 29
30do_configure_prepend () {
31 # Improve reproducibility for c++ object files
32 reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}"
33 sed -i "s:@RELATIVE_STAGING_INCDIR@:$reltivepath:g" ${S}/stringtable.h
34}
35
28do_install_append () { 36do_install_append () {
29 if [ ! -f ${D}${bindir}/stap ]; then 37 if [ ! -f ${D}${bindir}/stap ]; then
30 # translator disabled case, need to leave only minimal runtime 38 # translator disabled case, need to leave only minimal runtime