summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-10-04 16:37:53 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-05 10:10:10 +0100
commit16882885f656a2312b1d441cb800e1ee28f07dcf (patch)
tree940459bc52ead76448eb728cd8370d1aaba37ff2 /meta/recipes-kernel/systemtap/systemtap_git.bb
parent25f3a3d98098c72780e379c8d7d2a677f9557973 (diff)
downloadpoky-16882885f656a2312b1d441cb800e1ee28f07dcf.tar.gz
systemtap: rationalise dependencies
Boost is an optional dependency but avoid build non-determinism by adding it as DEPENDS. It is only for the shared pointer types so can be disabled explicitly if required. Turn sqlite into a PACKAGECONFIG. Add a patch for the "monitor" feature to control the optional dependencies on ncurses and json-c. Previously this was enabled for target only but enable it everwhere now that json-c is available for native/nativesdk. Of course all of this was predicated about systemtap needing systemtap-native to be built, but it turns out that this dependency is due to oe-core 507bd2 which adds systemtap-native as DEPENDS for convenience. Remove this dependency, if the user wants systemtap-native then they can build it explicitly. (From OE-Core rev: fb9dc1cf7a2d6d5e22beb68f17b4c9c8d1136e37) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index da30fa5e6d..43bf69e877 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -2,9 +2,7 @@ SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Lin
2 2
3require systemtap_git.inc 3require systemtap_git.inc
4 4
5DEPENDS = "elfutils sqlite3 systemtap-native ncurses json-c" 5DEPENDS = "boost elfutils"
6DEPENDS_class-native = "elfutils-native sqlite3-native gettext-native"
7DEPENDS_class-nativesdk = "nativesdk-elfutils nativesdk-sqlite3 nativesdk-gettext"
8 6
9RDEPENDS_${PN} += "python3-core bash" 7RDEPENDS_${PN} += "python3-core bash"
10 8
@@ -19,8 +17,10 @@ STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
19 17
20EXTRA_OECONF += "${STAP_DOCS} " 18EXTRA_OECONF += "${STAP_DOCS} "
21 19
22PACKAGECONFIG ??= "" 20PACKAGECONFIG ??= "sqlite monitor"
23PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" 21PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
22PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
24 24
25inherit autotools gettext pkgconfig 25inherit autotools gettext pkgconfig
26 26