summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.5.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-11-25 15:50:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-27 11:51:24 +0000
commit63335c87c1904287cdd5fd28d0ad6a73e985f2a4 (patch)
tree384da75c86a3ec90b1050a539800d898989029bc /meta/recipes-kernel/powertop/powertop_2.5.bb
parent9e7467657a437681b3fa1f2e831483ed90b0bc54 (diff)
downloadpoky-63335c87c1904287cdd5fd28d0ad6a73e985f2a4.tar.gz
powertop: upgrade to 2.5
(From OE-Core rev: 879cb228e4ad4a8901caf8eda630bc9355fd8dfa) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.5.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.5.bb b/meta/recipes-kernel/powertop/powertop_2.5.bb
new file mode 100644
index 0000000000..f37d7a76e0
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.5.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/powertop/sites/default/files/downloads/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "806bbcbd44fcea1f807c9582fc1f7d3e"
12SRC_URI[sha256sum] = "8b2c08a555d79e1c428863470c41cb023971d74ba4801d80a05e35adeec23c0b"
13
14inherit autotools gettext
15
16# we need to explicitly link with libintl in uClibc systems
17LDFLAGS += "${EXTRA_LDFLAGS}"
18EXTRA_LDFLAGS_libc-uclibc = "-lintl"
19
20# we do not want libncursesw if we can
21do_configure_prepend() {
22 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
23 sed -i -e "s/ncursesw//g" ${S}/configure.ac
24}
25
26inherit update-alternatives
27ALTERNATIVE_${PN} = "powertop"
28ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
29ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
30ALTERNATIVE_PRIORITY = "100"