summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.4.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-07-30 11:51:37 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-03 10:33:06 +0100
commit191365918394c9fa8c807805fe83a0194aa59c37 (patch)
treedbc6ea0908a2eb75b3343e377eb0634d7e28df2c /meta/recipes-kernel/powertop/powertop_2.4.bb
parente4a6815e446f09f9f38743422c443fc8ab35a810 (diff)
downloadpoky-191365918394c9fa8c807805fe83a0194aa59c37.tar.gz
powertop: upgrade to 2.4
(From OE-Core rev: af7214b7a24e283f7a17c63021e0c50904115f41) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.4.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.4.bb b/meta/recipes-kernel/powertop/powertop_2.4.bb
new file mode 100644
index 0000000000..465d117c57
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.4.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/powertop/sites/default/files/downloads/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "3aa686bb245d6683b86cba9a6a4b8c6d"
12SRC_URI[sha256sum] = "42796c94546ae7f3d232e41b7fa09b2532396ca389908ff528870311db6327b7"
13
14inherit autotools gettext
15
16# we need to explicitly link with libintl in uClibc systems
17LDFLAGS += "${EXTRA_LDFLAGS}"
18EXTRA_LDFLAGS_libc-uclibc = "-lintl"
19
20# we do not want libncursesw if we can
21do_configure_prepend() {
22 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
23 sed -i -e "s/ncursesw//g" ${S}/configure.ac
24}
25
26inherit update-alternatives
27ALTERNATIVE_${PN} = "powertop"
28ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
29ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
30ALTERNATIVE_PRIORITY = "100"