summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.12.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-31 17:52:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:27:30 +0100
commite4abbaf4fe6a70f7d9f47fdd026aced168d5bb0a (patch)
treedace4a83b8ac302897dc1b64251573fe9ff51103 /meta/recipes-kernel/powertop/powertop_2.12.bb
parentbeeff702910468d5301506bffa01cb07289b8c7e (diff)
downloadpoky-e4abbaf4fe6a70f7d9f47fdd026aced168d5bb0a.tar.gz
powertop: upgrade 2.10 -> 2.12
(From OE-Core rev: f1cb1f5b29ac25b75c0872c91e36bb16b69afc76) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.12.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.12.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.12.bb b/meta/recipes-kernel/powertop/powertop_2.12.bb
new file mode 100644
index 0000000000..f085d9b482
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.12.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "https://01.org/powertop/"
4BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla"
5DEPENDS = "ncurses libnl pciutils autoconf-archive"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "git://github.com/fenrus75/powertop;protocol=https \
10 file://0001-wakeup_xxx.h-include-limits.h.patch \
11"
12SRCREV = "6988eaaa5bbcfff1dd86f757006c6c48cec965c5"
13
14S = "${WORKDIR}/git"
15
16inherit autotools gettext pkgconfig bash-completion
17
18# we do not want libncursesw if we can
19do_configure_prepend() {
20 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
21 sed -i -e "s/ncursesw//g" ${S}/configure.ac
22 mkdir -p ${B}/src/tuning/
23 echo "${PV}" > ${S}/version-long
24 echo "${PV}" > ${S}/version-short
25 cp ${STAGING_DATADIR}/aclocal/ax_require_defined.m4 ${S}/m4/
26}
27
28inherit update-alternatives
29ALTERNATIVE_${PN} = "powertop"
30ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_PRIORITY = "100"