summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.10.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-17 17:26:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-18 16:24:39 +0000
commit33c37397a317739155190da33305a6df11613445 (patch)
tree7d5c9f817c7ac8be4f8d469ac4cd5826e9b32605 /meta/recipes-kernel/powertop/powertop_2.10.bb
parent34d9e930697768bc5adfd3522077698db4d96ed3 (diff)
downloadpoky-33c37397a317739155190da33305a6df11613445.tar.gz
powertop: update to 2.10
(From OE-Core rev: d93292c1cc491e43ed5af853b269889ea996c4f9) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.10.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.10.bb b/meta/recipes-kernel/powertop/powertop_2.10.bb
new file mode 100644
index 0000000000..d943ba9f6e
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.10.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop-v${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "a69bd55901cf919cc564187402ea2c9c"
13SRC_URI[sha256sum] = "d3b7459eaba7d01c8841dd33a3b4d369416c01e9bd8951b0d88234cf18fe4a75"
14
15UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
16UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar"
17
18inherit autotools gettext pkgconfig
19
20S = "${WORKDIR}/${BPN}-v${PV}"
21
22# we do not want libncursesw if we can
23do_configure_prepend() {
24 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
25 sed -i -e "s/ncursesw//g" ${S}/configure.ac
26 mkdir -p ${B}/src/tuning/
27}
28
29inherit update-alternatives
30ALTERNATIVE_${PN} = "powertop"
31ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
33ALTERNATIVE_PRIORITY = "100"