summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.13.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-04-11 16:05:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-22 14:45:04 +0100
commit7195096f5754245f2b495a1629c6eb5ae6427afe (patch)
tree9cb7874830ec94eddcfec5d28a3a6711a0308c50 /meta/recipes-kernel/powertop/powertop_1.13.bb
parent4178360b2ba645f3519d227e27c0beb80768d801 (diff)
downloadpoky-7195096f5754245f2b495a1629c6eb5ae6427afe.tar.gz
powertop: add 2.3
With all tweaks from 1.13: - uclibc buildable - libncurses instead of libncursesw Changes from v3: - proper update-alternatives path (From OE-Core rev: 188862de64bc2b61f8510082c8a6e5929d2b79d1) Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
deleted file mode 100644
index db54ed0f59..0000000000
--- a/meta/recipes-kernel/powertop/powertop_1.13.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
3HOMEPAGE = "http://www.lesswatts.org/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9DEPENDS = "virtual/libintl ncurses"
10
11# powertop 1.13 needs lspci
12RDEPENDS_${PN} = "pciutils"
13
14PR = "r4"
15
16SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
17 file://stub_out_the_ncurses_calls_in_dump_mode.patch \
18 "
19
20SRC_URI[md5sum] = "78aa17c8f55178004223bf236654298e"
21SRC_URI[sha256sum] = "2bc866089496877dd26d2d316ad5763ab8ecb5e28aefba44bc5d355dcdc58d98"
22
23CFLAGS += "${LDFLAGS}"
24EXTRA_OEMAKE = "VERSION=\"${PV}\" EXTRA_LIBS=${EXTRA_LIBS}"
25
26EXTRA_LIBS_libc-uclibc = "-lintl"
27
28do_configure() {
29 # We do not build ncurses with wide char support
30 sed -i -e 's:lncursesw:lncurses ${EXTRA_LIBS}:g' ${S}/Makefile
31}
32
33do_install() {
34 oe_runmake install DESTDIR=${D}
35}
36
37inherit update-alternatives
38ALTERNATIVE_${PN} = "powertop"
39ALTERNATIVE_TARGET[powertop] = "${bindir}/powertop"
40ALTERNATIVE_LINK_NAME[powertop] = "${base_bindir}/powertop"
41ALTERNATIVE_PRIORITY = "100"