summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-03-15 11:41:20 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-20 09:59:32 +0000
commitda4e85506068ebabe6eca50fe337fdb466f02070 (patch)
tree322380cc63cc8856fc0d6b4e93e7dcfbdbd46160 /meta/recipes-kernel/perf/perf.bb
parentf6f688842bc79e26ced18a2d654f06ea9c3961cd (diff)
downloadpoky-da4e85506068ebabe6eca50fe337fdb466f02070.tar.gz
perf: enable support for libaudit
perf needs audit-python to be able to show syscall names and for 'perf trace' to work. Enable dependency on audit-python if present in PACKAGECONFIG. It's disabled by default since audit as of now is in meta-selinux. Fixes [YOCTO #3343] Fixes [YOCTO #3358] (From OE-Core rev: c386abacae89a148e77ffa51630c7917e90406f9) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index d798492562..872b5f028a 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -22,6 +22,9 @@ PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
22PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap" 22PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
23PACKAGECONFIG[jvmti] = ",NO_JVMTI=1" 23PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
24 24
25# libaudit support would need scripting to be enabled
26PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
27
25DEPENDS = " \ 28DEPENDS = " \
26 virtual/${MLPREFIX}libc \ 29 virtual/${MLPREFIX}libc \
27 ${MLPREFIX}elfutils \ 30 ${MLPREFIX}elfutils \
@@ -216,7 +219,7 @@ PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
216RDEPENDS_${PN} += "elfutils bash" 219RDEPENDS_${PN} += "elfutils bash"
217RDEPENDS_${PN}-doc += "man" 220RDEPENDS_${PN}-doc += "man"
218RDEPENDS_${PN}-archive =+ "bash" 221RDEPENDS_${PN}-archive =+ "bash"
219RDEPENDS_${PN}-python =+ "bash python python-modules" 222RDEPENDS_${PN}-python =+ "bash python python-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
220RDEPENDS_${PN}-perl =+ "bash perl perl-modules" 223RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
221RDEPENDS_${PN}-tests =+ "python" 224RDEPENDS_${PN}-tests =+ "python"
222 225