summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorZubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>2016-11-23 13:47:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:07 +0000
commit902f1622341e0f2c59534d505efd53349a0c2dcb (patch)
tree9133383d6f9a626a0df6b2395303a5cd526d66c8 /meta/recipes-kernel/perf/perf.bb
parent6dc16c8907343e7ef638f13bf00945d0a1268f7c (diff)
downloadpoky-902f1622341e0f2c59534d505efd53349a0c2dcb.tar.gz
perf: Add EXTRA_LDFLAGS for MIPS N32
MIPS N32 requires EXTRA_LDFLAGS to link correctly. (From OE-Core rev: 5b3cc758ddd8bfe6e52e6287ddf463c080673a7e) Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 25ae83cef3..6cdaa68b57 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -80,6 +80,7 @@ EXTRA_OEMAKE = '\
80 AR="${AR}" \ 80 AR="${AR}" \
81 LD="${LD}" \ 81 LD="${LD}" \
82 EXTRA_CFLAGS="-ldw" \ 82 EXTRA_CFLAGS="-ldw" \
83 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
83 perfexecdir=${libexecdir} \ 84 perfexecdir=${libexecdir} \
84 NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${LIBUNWIND_DEFINES} \ 85 NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${LIBUNWIND_DEFINES} \
85 ${SCRIPTING_DEFINES} ${LIBNUMA_DEFINES} \ 86 ${SCRIPTING_DEFINES} ${LIBNUMA_DEFINES} \
@@ -98,6 +99,12 @@ EXTRA_OEMAKE += "\
98 'infodir=${@os.path.relpath(infodir, prefix)}' \ 99 'infodir=${@os.path.relpath(infodir, prefix)}' \
99" 100"
100 101
102PERF_EXTRA_LDFLAGS = ""
103
104# MIPS N32
105PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
106PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
107
101do_compile() { 108do_compile() {
102 # Linux kernel build system is expected to do the right thing 109 # Linux kernel build system is expected to do the right thing
103 unset CFLAGS 110 unset CFLAGS