summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-07-27 01:02:03 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-04 15:22:24 +0100
commit7759b4844f59d6cd416e10329ed51548c872c602 (patch)
tree633f09d7feebf975170dd0a18e512a1b2fd5e338 /meta/recipes-kernel/perf/perf.bb
parent9ddb513a7ff3c2cb213f22db95321c490605c6c8 (diff)
downloadpoky-7759b4844f59d6cd416e10329ed51548c872c602.tar.gz
perf: enable man pages for 'help' functionality
When using 'perf help <subcommand>', it can't find 'man' command and pages for perf. The perf man pages depends on the xmlto-native and asciidoc-native, so we just need to add the two packages to the DEPENDS variable and add 'man'to RDEPENDS_perf-doc. (From OE-Core rev: bbff6b07256d63d318066eb1357763467532dd70) Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 171d23f454..1e84a2231b 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -30,6 +30,8 @@ DEPENDS = " \
30 ${SCRIPTING_DEPENDS} \ 30 ${SCRIPTING_DEPENDS} \
31 ${LIBUNWIND_DEPENDS} \ 31 ${LIBUNWIND_DEPENDS} \
32 bison flex xz \ 32 bison flex xz \
33 xmlto-native \
34 asciidoc-native \
33" 35"
34 36
35do_configure[depends] += "virtual/kernel:do_shared_workdir" 37do_configure[depends] += "virtual/kernel:do_shared_workdir"
@@ -90,7 +92,6 @@ EXTRA_OEMAKE += "\
90 'sharedir=${datadir}' \ 92 'sharedir=${datadir}' \
91 'sysconfdir=${sysconfdir}' \ 93 'sysconfdir=${sysconfdir}' \
92 'perfexecdir=${libexecdir}/perf-core' \ 94 'perfexecdir=${libexecdir}/perf-core' \
93 \
94 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \ 95 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
95 'sharedir=${@os.path.relpath(datadir, prefix)}' \ 96 'sharedir=${@os.path.relpath(datadir, prefix)}' \
96 'mandir=${@os.path.relpath(mandir, prefix)}' \ 97 'mandir=${@os.path.relpath(mandir, prefix)}' \
@@ -138,6 +139,13 @@ do_configure_prepend () {
138 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ 139 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
139 ${S}/tools/perf/config/Makefile 140 ${S}/tools/perf/config/Makefile
140 fi 141 fi
142 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
143 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
144 # will use the relative path 'share/man', in the way it will resulting in
145 # incorrect installation for man pages.
146 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
147 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
148 fi
141 if [ -e "${S}/tools/perf/Makefile.perf" ]; then 149 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
142 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ 150 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
143 ${S}/tools/perf/Makefile.perf 151 ${S}/tools/perf/Makefile.perf
@@ -197,6 +205,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
197PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python" 205PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
198 206
199RDEPENDS_${PN} += "elfutils bash" 207RDEPENDS_${PN} += "elfutils bash"
208RDEPENDS_${PN}-doc += "man"
200RDEPENDS_${PN}-archive =+ "bash" 209RDEPENDS_${PN}-archive =+ "bash"
201RDEPENDS_${PN}-python =+ "bash python python-modules" 210RDEPENDS_${PN}-python =+ "bash python python-modules"
202RDEPENDS_${PN}-perl =+ "bash perl perl-modules" 211RDEPENDS_${PN}-perl =+ "bash perl perl-modules"