summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-08-30 12:49:00 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-05 11:56:01 +0100
commit62989123351f47332442ae947b6e021322ff037f (patch)
tree4886db8553670ba9a68bccad9725ac815e3a8a9b /meta/recipes-kernel/perf/perf.bb
parent4d1a1242896a18bceb0318b05e1106878e6fd311 (diff)
downloadpoky-62989123351f47332442ae947b6e021322ff037f.tar.gz
perf: adapt to Makefile.config
commit 4842576cd857 [perf tools: Move config/Makefile into Makefile.config] relocated the configuration Makefile of perf. As such, we need to adapt our fixup routines to work with the Makefile no matter where it is. (From OE-Core rev: 573d584ff704025387782e35ed344e73294d6d0a) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index d4855488ae..88e3a0a78c 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -133,11 +133,17 @@ do_configure_prepend () {
133 # with each other if its in the shared source directory 133 # with each other if its in the shared source directory
134 # 134 #
135 if [ -e "${S}/tools/perf/config/Makefile" ]; then 135 if [ -e "${S}/tools/perf/config/Makefile" ]; then
136 perfconfig="${S}/tools/perf/config/Makefile"
137 fi
138 if [ -e "${S}/tools/perf/Makefile.config" ]; then
139 perfconfig="${S}/tools/perf/Makefile.config"
140 fi
141 if [ -n "${perfconfig}" ]; then
136 # Match $(prefix)/$(lib) and $(prefix)/lib 142 # Match $(prefix)/$(lib) and $(prefix)/lib
137 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \ 143 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
138 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \ 144 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
139 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ 145 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
140 ${S}/tools/perf/config/Makefile 146 ${perfconfig}
141 fi 147 fi
142 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)" 148 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
143 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it 149 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
@@ -214,6 +220,7 @@ RDEPENDS_${PN}-tests =+ "python"
214RSUGGESTS_SCRIPTING = "${@perf_feature_enabled('perf-scripting', '${PN}-perl ${PN}-python', '',d)}" 220RSUGGESTS_SCRIPTING = "${@perf_feature_enabled('perf-scripting', '${PN}-perl ${PN}-python', '',d)}"
215RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}" 221RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
216 222
223#FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core /usr/lib64/traceevent ${libdir}/traceevent"
217FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent" 224FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent"
218FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive" 225FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
219FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests" 226FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"