summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-01-10 14:31:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-14 09:11:57 +0000
commit26eecd3324cbe5edb6856adff7876495b45a7616 (patch)
treef5a843b507a33f33ec44c2e708b8924248957ff0 /meta/recipes-kernel/perf/perf.bb
parent20ccd395fec1c1d7240a513d37e2f67542e78e28 (diff)
downloadpoky-26eecd3324cbe5edb6856adff7876495b45a7616.tar.gz
perf: conditionalise pythonnative and perlnative inherits
Only inherit these classes (and so, add perl-native and python-native to DEPENDS) if the scripting PACKAGECONFIG is actually enabled. (From OE-Core rev: 6d56f14a7276f076dfe625bc4d2c16a6a4635153) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index bb943ecd1c..1bad6f4e9b 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -35,9 +35,10 @@ do_configure[depends] += "virtual/kernel:do_shared_workdir"
35 35
36PROVIDES = "virtual/perf" 36PROVIDES = "virtual/perf"
37 37
38inherit linux-kernel-base kernel-arch pythonnative 38inherit linux-kernel-base kernel-arch
39 39
40# needed for building the tools/perf Python bindings 40# needed for building the tools/perf Python bindings
41inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'pythonnative', '', d)}
41inherit python-dir 42inherit python-dir
42export PYTHON_SITEPACKAGES_DIR 43export PYTHON_SITEPACKAGES_DIR
43 44
@@ -47,7 +48,8 @@ export WERROR = "0"
47do_populate_lic[depends] += "virtual/kernel:do_patch" 48do_populate_lic[depends] += "virtual/kernel:do_patch"
48 49
49# needed for building the tools/perf Perl binding 50# needed for building the tools/perf Perl binding
50inherit perlnative cpan-base 51inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perlnative', '', d)}
52inherit cpan-base
51# Env var which tells perl if it should use host (no) or target (yes) settings 53# Env var which tells perl if it should use host (no) or target (yes) settings
52export PERLCONFIGTARGET = "${@is_target(d)}" 54export PERLCONFIGTARGET = "${@is_target(d)}"
53export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}/CORE" 55export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}/CORE"