diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2014-08-12 04:10:19 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-09-03 11:09:03 +0100 |
commit | 9bf365cf1a9461d77d19fb27171a1b794f33c6dd (patch) | |
tree | 5b815086d1ff7da6f558dfdb00169f70ae48217f /meta/recipes-kernel/perf/perf.bb | |
parent | cdb77523a56b3e0bc7625614bfb8066b8c2ff52f (diff) | |
download | poky-9bf365cf1a9461d77d19fb27171a1b794f33c6dd.tar.gz |
perf.bb: fix multilib build
Fixed:
$ bitbake perf lib32-perf
ERROR: QA Issue: lib32-perf: Files/directories were installed but not shipped
/usr/lib64
/usr/lib64/traceevent
/usr/lib64/traceevent/plugins
/usr/lib64/traceevent/plugins/plugin_function.so
/usr/lib64/traceevent/plugins/plugin_scsi.so
/usr/lib64/traceevent/plugins/plugin_hrtimer.so
/usr/lib64/traceevent/plugins/plugin_kmem.so
/usr/lib64/traceevent/plugins/plugin_jbd2.so
/usr/lib64/traceevent/plugins/plugin_xen.so
/usr/lib64/traceevent/plugins/plugin_mac80211.so
/usr/lib64/traceevent/plugins/plugin_cfg80211.so
/usr/lib64/traceevent/plugins/plugin_sched_switch.so
/usr/lib64/traceevent/plugins/plugin_kvm.so [installed-vs-shipped]
The perf.do_configure edits kernel's
${STAGING_KERNEL_DIR}/tools/perf/config/Makefile, there would be
problems since kernel doesn't have multilib, and the build result is
undetermined.
Previously, the sed command changed libdir to /usr/lib64 (or 32) in the
Makefile, so the build result was different if we build perf (64) first
or lib32-perf first.
Use the weak assignment "libdir ?=" to instead of "libdir =" will fix
the problem since the multilib builds are in different processes, and
they won't affect each other any more.
The sed command will match both $(prefix)/$(lib) and $(prefix)/lib since
the Makefile may has been modified before this patch.
(From OE-Core rev: c62d693e1341be4afcaaeb1ee37360ecac71f46a)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r-- | meta/recipes-kernel/perf/perf.bb | 8 |
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb index bfd210cf2e..ebfedb91d7 100644 --- a/meta/recipes-kernel/perf/perf.bb +++ b/meta/recipes-kernel/perf/perf.bb | |||
@@ -121,10 +121,12 @@ do_configure_prepend () { | |||
121 | # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit | 121 | # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit |
122 | # build, with a 64 bit multilib, the arch won't match and the detection of a | 122 | # build, with a 64 bit multilib, the arch won't match and the detection of a |
123 | # 64 bit build (and library) are not exected. To ensure that libraries are | 123 | # 64 bit build (and library) are not exected. To ensure that libraries are |
124 | # installed to the correct location, we can make the substitution in the | 124 | # installed to the correct location, we can use the weak assignment in the |
125 | # config/Makefile. For non multilib builds, this has no impact. | 125 | # config/Makefile. |
126 | if [ -e "${S}/tools/perf/config/Makefile" ]; then | 126 | if [ -e "${S}/tools/perf/config/Makefile" ]; then |
127 | sed -i 's,libdir = $(prefix)/$(lib),libdir = $(prefix)/${baselib},' ${S}/tools/perf/config/Makefile | 127 | # Match $(prefix)/$(lib) and $(prefix)/lib |
128 | sed -i 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \ | ||
129 | ${S}/tools/perf/config/Makefile | ||
128 | fi | 130 | fi |
129 | # We need to ensure the --sysroot option in CC is preserved | 131 | # We need to ensure the --sysroot option in CC is preserved |
130 | if [ -e "${S}/tools/perf/Makefile.perf" ]; then | 132 | if [ -e "${S}/tools/perf/Makefile.perf" ]; then |