diff options
author | Henning Heinold <henning@itconsulting-heinold.de> | 2014-06-09 23:21:29 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-06-13 12:31:38 +0100 |
commit | 36c3e923df85e685b707fe6bd84b053a5e366fe4 (patch) | |
tree | 8ba762110e1c94a029d727ffd1846a867aee8429 /meta/recipes-kernel/perf/perf.bb | |
parent | 949953d50c95023bf47f9705d413fd93cbee0753 (diff) | |
download | poky-36c3e923df85e685b707fe6bd84b053a5e366fe4.tar.gz |
perf: split packging
* some fundamental perf commands can work
without the dependency on perl, python or bash
make them separate packages and RSUGGEST them
* bump PR
The patch was sponsored by sysmocom
(From OE-Core rev: 6d1c0cde05dbab5ca84b1bbd8abeecf8df49e37b)
Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r-- | meta/recipes-kernel/perf/perf.bb | 22 |
1 files changed, 17 insertions, 5 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb index 9996f663cd..92d37e269c 100644 --- a/meta/recipes-kernel/perf/perf.bb +++ b/meta/recipes-kernel/perf/perf.bb | |||
@@ -9,7 +9,7 @@ as well." | |||
9 | LICENSE = "GPLv2" | 9 | LICENSE = "GPLv2" |
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" |
11 | 11 | ||
12 | PR = "r8" | 12 | PR = "r9" |
13 | 13 | ||
14 | require perf-features.inc | 14 | require perf-features.inc |
15 | 15 | ||
@@ -27,9 +27,6 @@ DEPENDS = "virtual/kernel \ | |||
27 | bison flex \ | 27 | bison flex \ |
28 | " | 28 | " |
29 | 29 | ||
30 | SCRIPTING_RDEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl perl-modules python', '',d)}" | ||
31 | RDEPENDS_${PN} += "elfutils bash ${SCRIPTING_RDEPENDS}" | ||
32 | |||
33 | PROVIDES = "virtual/perf" | 30 | PROVIDES = "virtual/perf" |
34 | 31 | ||
35 | inherit linux-kernel-base kernel-arch pythonnative | 32 | inherit linux-kernel-base kernel-arch pythonnative |
@@ -153,8 +150,23 @@ python do_package_prepend() { | |||
153 | 150 | ||
154 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 151 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
155 | 152 | ||
153 | |||
154 | PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python" | ||
155 | |||
156 | RDEPENDS_${PN} += "elfutils" | ||
157 | RDEPENDS_${PN}-archive =+ "bash" | ||
158 | RDEPENDS_${PN}-python =+ "bash python" | ||
159 | RDEPENDS_${PN}-perl =+ "bash perl perl-modules" | ||
160 | |||
161 | RSUGGESTS_SCRIPTING = "${@perf_feature_enabled('perf-scripting', '${PN}-perl ${PN}-python', '',d)}" | ||
162 | RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}" | ||
163 | |||
156 | FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent" | 164 | FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent" |
157 | FILES_${PN}-dbg += "${libdir}/python*/site-packages/.debug" | 165 | FILES_${PN}-dbg += "${libdir}/python*/site-packages/.debug" |
158 | FILES_${PN} += "${libdir}/python*/site-packages" | 166 | FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive" |
167 | FILES_${PN}-tests = "${libdir}/perf/perf-core/tests" | ||
168 | FILES_${PN}-python = "${libdir}/python*/site-packages ${libdir}/perf/perf-core/scripts/python" | ||
169 | FILES_${PN}-perl = "${libdir}/perf/perf-core/scripts/perl" | ||
170 | |||
159 | 171 | ||
160 | INHIBIT_PACKAGE_DEBUG_SPLIT="1" | 172 | INHIBIT_PACKAGE_DEBUG_SPLIT="1" |