diff options
author | Changqing Li <changqing.li@windriver.com> | 2020-04-01 10:32:55 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2020-04-02 15:24:59 +0100 |
commit | 40f37ab2312ada1f4d6e44d270f71d2e4e0ec637 (patch) | |
tree | 2b8ccd43d549fe58d817793d14e9904fd6f19c03 /meta/recipes-kernel/perf/perf.bb | |
parent | 87ef247ed4ebb6b4069526e83e1a85f363058a14 (diff) | |
download | poky-40f37ab2312ada1f4d6e44d270f71d2e4e0ec637.tar.gz |
perf: fix compile error when rebuilding
Fix error like:
Makefile.perf:597: recipe for target
'intel_x86_64-wrs-linux/perf/1.0-r9/perf-1.0/perf-in.o] Error 2
Makefile.perf:220: recipe for target 'sub-make' failed
make[1]: *** [sub-make] Error 2
Makefile:69: recipe for target 'all' failed
make: *** [all] Error 2
during rebuilding, when kernel version changed, some
source files also maybe changed. It could happened
that the source under ${S} messed up with some already
dropped files and also new files. Fix by clean the ${S}
before copy source files.
(From OE-Core rev: 57b4745cca8d486c1f20b8f01f4a25cb59c4b968)
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r-- | meta/recipes-kernel/perf/perf.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb index e005eb082b..c4b7b77e99 100644 --- a/meta/recipes-kernel/perf/perf.bb +++ b/meta/recipes-kernel/perf/perf.bb | |||
@@ -147,6 +147,7 @@ python copy_perf_source_from_kernel() { | |||
147 | src_dir = d.getVar("STAGING_KERNEL_DIR") | 147 | src_dir = d.getVar("STAGING_KERNEL_DIR") |
148 | dest_dir = d.getVar("S") | 148 | dest_dir = d.getVar("S") |
149 | bb.utils.mkdirhier(dest_dir) | 149 | bb.utils.mkdirhier(dest_dir) |
150 | bb.utils.prunedir(dest_dir) | ||
150 | for s in sources: | 151 | for s in sources: |
151 | src = oe.path.join(src_dir, s) | 152 | src = oe.path.join(src_dir, s) |
152 | dest = oe.path.join(dest_dir, s) | 153 | dest = oe.path.join(dest_dir, s) |