summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/modutils/modutils_2.4.27.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-kernel/modutils/modutils_2.4.27.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/modutils/modutils_2.4.27.bb')
-rw-r--r--meta/recipes-kernel/modutils/modutils_2.4.27.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/recipes-kernel/modutils/modutils_2.4.27.bb b/meta/recipes-kernel/modutils/modutils_2.4.27.bb
new file mode 100644
index 0000000000..a5a9231322
--- /dev/null
+++ b/meta/recipes-kernel/modutils/modutils_2.4.27.bb
@@ -0,0 +1,88 @@
1SECTION = "base"
2DESCRIPTION = "These utilities are intended to make a Linux modular kernel \
3manageable for all users, administrators and distribution maintainers."
4LICENSE = "GPLv2"
5DEPENDS = "bison-native"
6PR = "r9"
7
8SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/modutils/v2.4/modutils-${PV}.tar.bz2 \
9 file://lex.l.diff;patch=1 \
10 file://modutils-notest.patch;patch=1 \
11 file://configure.patch;patch=1 \
12 file://program_prefix.patch;patch=1 \
13 file://armeb.patch;patch=1 \
14 file://gcc4.patch;patch=1"
15
16inherit autotools
17
18# modutils go in /sbin
19sbindir = "/sbin"
20EXTRA_OECONF = "--disable-strip"
21export BUILDCC = "${BUILD_CC}"
22export BUILDCFLAGS = "${BUILD_CFLAGS}"
23
24do_install () {
25 oe_runmake 'DESTDIR=${D}' install
26 install -d ${D}${sysconfdir}
27 rm ${D}${base_sbindir}/lsmod
28 install -d ${D}${base_bindir}/
29 ln -s ../sbin/insmod ${D}${base_bindir}/lsmod
30 for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do mv ${D}/$f ${D}/$f.24
31 done
32}
33
34pkg_postinst_modutils () {
35#!/bin/sh
36for f in sbin/insmod sbin/modprobe sbin/rmmod bin/lsmod; do
37 bn=`basename $f`
38 update-alternatives --install /$f $bn /$f.24 10
39done
40if test -n "$D"; then
41 D="-r $D"
42 if test -n "`which ${TARGET_PREFIX}depmod-2.4`"; then
43 for kerneldir in `ls -p $D/lib/modules|grep /`; do
44 kernelver=`basename $kerneldir`
45 ${TARGET_PREFIX}depmod-2.4 -a -b $D -C ${IMAGE_ROOTFS}/${sysconfdir}/modules.conf -r $kernelver
46 done
47 fi
48fi
49update-rc.d $D modutils.sh start 20 S .
50}
51
52pkg_prerm_modutils () {
53#!/bin/sh
54for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
55bn=`basename $f`
56 update-alternatives --remove $bn /$f.24
57done
58if test -n "$D"; then
59 D="-r $D"
60fi
61update-rc.d $D modutils.sh remove
62}
63
64pkg_postinst_modutils-depmod() {
65#!/bin/sh
66update-alternatives --install /sbin/depmod depmod /sbin/depmod.24 10
67}
68
69pkg_postinst_modutils-modinfo() {
70#!/bin/sh
71update-alternatives --install /sbin/modinfo modinfo /sbin/modinfo.24 10
72}
73
74pkg_prerm_modutils-depmod() {
75#!/bin/sh
76update-alternatives --remove depmod /sbin/depmod.24
77}
78
79pkg_prerm_modutils-modinfo() {
80#!/bin/sh
81update-alternatives --remove modinfo /sbin/modinfo.24
82}
83
84PACKAGES = "modutils-depmod modutils-modinfo modutils-doc modutils"
85
86FILES_modutils-depmod = "sbin/depmod.24"
87FILES_modutils-modinfo = "sbin/modinfo.24"
88RDEPENDS_modutils = "modutils-depmod"