diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-05-27 13:51:07 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2020-06-05 21:36:30 +0100 |
commit | 4c582f5cf123c70678a8f0fea77a5b3504eb6f8d (patch) | |
tree | 142865b739acd1357917738990d77b9c52a7a1a5 /meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb | |
parent | 9aefaf5de989d5ff351ae7f255898523746ca0f2 (diff) | |
download | poky-4c582f5cf123c70678a8f0fea77a5b3504eb6f8d.tar.gz |
make-mod-scripts: Fix a rare build race condition
There is a build break which rarely happens but is seen often enough
with 4.1 kernel based builds
/bin/sh: 1: scripts/basic/fixdep: Permission denied
scripts/Makefile.host:124: recipe for target 'scripts/dtc/srcpos.o' failed
make[3]: *** [scripts/dtc/srcpos.o] Error 126
this patch sequences the build targets so it can work reliably with
different kernel versions
Divide the target into scripts_basic scripts is not
strictly necessary and was simply what was used for
testing on kernel 4.1, which is quite an old kernel
perhaps just using scripts is sufficient, but it is not tested to not
known will cause the build race as seen above.
(From OE-Core rev: 8a7da39c04fbab1280c464f39a791e4fbd1e7da9)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 55ac6e2d251287419138931aa0d0894cf1267787)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb')
-rw-r--r-- | meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb | 7 |
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb index 0be1422a24..c7edb20ee4 100644 --- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb +++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb | |||
@@ -23,7 +23,8 @@ EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP=" | |||
23 | # | 23 | # |
24 | do_configure() { | 24 | do_configure() { |
25 | unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS | 25 | unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS |
26 | oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \ | 26 | for t in prepare scripts_basic scripts; do |
27 | -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare | 27 | oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \ |
28 | 28 | -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} $t | |
29 | done | ||
29 | } | 30 | } |