summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-13 19:51:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-23 08:48:39 +0100
commit271b9b6873ce1e79587325b4dd35e4103d5a1258 (patch)
treeaf1fcc7313ecde57df5cca79cfaceccc3d350e54 /meta/recipes-kernel/lttng/lttng-ust_git.bb
parent51b590db259375aa6259845862ca9020ed264b05 (diff)
downloadpoky-271b9b6873ce1e79587325b4dd35e4103d5a1258.tar.gz
lttng-ust: 2.6.1 -> 2.6.2
* Remove add-aarch64.patch since it is already in the source. * Rename lttng-ust_2.6.1.bb -> lttng-ust_git.bb (From OE-Core rev: f5b03208c0ae0f47dddec6e39712fb0f1d041ebc) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_git.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_git.bb b/meta/recipes-kernel/lttng/lttng-ust_git.bb
new file mode 100644
index 0000000000..ae4afd3d89
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
21SRCREV = "c49ee9040ada6984c880756614e8a6f7fd645bd6"
22PE = "2"
23PV = "2.6.2+git${SRCPV}"
24
25SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.6 \
26 file://lttng-ust-doc-examples-disable.patch \
27 file://lttng-ust-Fix-live-timer-calculation-error.patch \
28 "
29
30S = "${WORKDIR}/git"
31
32do_configure_prepend () {
33 ( cd ${S}; ${S}/bootstrap )
34}