summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb
diff options
context:
space:
mode:
authorNathan Lynch <nathan_lynch@mentor.com>2017-06-16 16:39:50 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 15:21:33 +0100
commita910c2e8104455e87db56b393a0c63a0b0280aca (patch)
tree714cd3a91b9bc0d465e92bc1d694ad5b0d79c91d /meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb
parent4d54ebab89595f0df38c58311b7bb012f591ec77 (diff)
downloadpoky-a910c2e8104455e87db56b393a0c63a0b0280aca.tar.gz
lttng-ust: update to 2.9.1
Miscellaneous fixes. (From OE-Core rev: fa52a9a7051920521eed6c6d5dae9f8c6f749fe1) Signed-off-by: Nathan Lynch <nathan_lynch@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb b/meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb
new file mode 100644
index 0000000000..f7e01bb403
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.9.1.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package manpages
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python3-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
21PE = "2"
22
23SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
24 file://lttng-ust-doc-examples-disable.patch \
25 "
26SRC_URI[md5sum] = "5a5636fc3d9aa370f65b25a802a79e6e"
27SRC_URI[sha256sum] = "b891d267cdbbbd11cf34751f66c21c4a7fdc0eec3c1b53be2c40dca073b7daa4"
28
29PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
30
31do_install_append() {
32 # Patch python tools to use Python 3; they should be source compatible, but
33 # still refer to Python 2 in the shebang
34 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
35}