summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
diff options
context:
space:
mode:
authorNathan Lynch <nathan_lynch@mentor.com>2017-01-16 12:51:43 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:47:21 +0000
commit2a6224f4fdfc3672ad620c5045c9e460f97f9393 (patch)
tree07363f63b5a9236b99db5192d920ff77f7e33dd7 /meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
parent2acc2f708ba159d36638dcddd0490232072605c4 (diff)
downloadpoky-2a6224f4fdfc3672ad620c5045c9e460f97f9393.tar.gz
lttng-ust: upgrade to 2.9.0
buildhistory-diff says: /usr/lib/liblttng-ust-python-agent.so.0 was removed /usr/lib/liblttng-ust-python-agent.so.0.0.0 was removed This is because prior versions of lttng-ust unconditionally built the Python agent libraries; this was fixed upstream in 21ddb8e ("Only build python lib when agent is enabled"). Switch to using release tarballs. (From OE-Core rev: a40bb2b7991adf5ef7121a45461747226c04bac1) Signed-off-by: Nathan Lynch <nathan_lynch@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb b/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
new file mode 100644
index 0000000000..9cdefddf16
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package manpages
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python3-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
21PE = "2"
22
23SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
24 file://lttng-ust-doc-examples-disable.patch \
25 "
26SRC_URI[md5sum] = "77f3378ba37a36801420bce87b702e9c"
27SRC_URI[sha256sum] = "4d541a863f42dfc685ca05024027a442c70d03594c154a43e62bc109b1ea5daf"
28
29PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
30
31do_install_append() {
32 # Patch python tools to use Python 3; they should be source compatible, but
33 # still refer to Python 2 in the shebang
34 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
35}