summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-15 08:18:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-16 08:29:59 +0100
commita9e49336dcddf8b2a43116e7850c3e731786fb86 (patch)
treee423884b112a20d22b70c38699f183464a40e2e8 /meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb
parent4f7ea3fef7278d0f1f521b346a2cbe87aa2b9202 (diff)
downloadpoky-a9e49336dcddf8b2a43116e7850c3e731786fb86.tar.gz
lttng-ust: Upgrade 2.12.1 -> 2.12.2
(From OE-Core rev: 03b9c9ab5e74c4e825a023e54fe8891f6f6cc809) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb b/meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb
new file mode 100644
index 0000000000..e340ff3460
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.12.2.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
12 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
13 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
14"
15
16inherit autotools lib_package manpages python3native
17
18include lttng-platforms.inc
19
20EXTRA_OECONF = "--disable-numa"
21
22DEPENDS = "liburcu util-linux"
23RDEPENDS_${PN}-bin = "python3-core"
24
25# For backwards compatibility after rename
26RPROVIDES_${PN} = "lttng2-ust"
27RREPLACES_${PN} = "lttng2-ust"
28RCONFLICTS_${PN} = "lttng2-ust"
29
30PE = "2"
31
32SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
33 file://0001-python-lttngust-Makefile.am-Add-install-lib-to-setup.patch \
34 "
35
36SRC_URI[sha256sum] = "bcd0f064b6ca88c72d84e760eac3472ae5c828411c634435922bee9fce359fc7"
37
38CVE_PRODUCT = "ust"
39
40PACKAGECONFIG[examples] = "--enable-examples, --disable-examples,"
41PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
42PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3"
43
44FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*"
45FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a"
46FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la"
47
48do_install_append() {
49 # Patch python tools to use Python 3; they should be source compatible, but
50 # still refer to Python 2 in the shebang
51 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
52}