summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-12 16:36:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:25:42 +0000
commit588730900619ff3752cca5d24b9f72249d7680bc (patch)
tree22bd0f1c9180ef4c8dcd3630e618eb323689f745 /meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb
parentd539ca360ebcc303da692e85a6544959322850f9 (diff)
downloadpoky-588730900619ff3752cca5d24b9f72249d7680bc.tar.gz
lttng-ust: update to 2.11.0
Remove patch as issue addressed upstream. (From OE-Core rev: 0d35cf40fd0e80513036a1d741a744f40a399bc0) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb b/meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb
new file mode 100644
index 0000000000..6d7c05e65e
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.11.0.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
12 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
13 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
14"
15
16inherit autotools lib_package manpages python3native
17
18EXTRA_OECONF = "--disable-numa"
19
20DEPENDS = "liburcu util-linux"
21RDEPENDS_${PN}-bin = "python3-core"
22
23# For backwards compatibility after rename
24RPROVIDES_${PN} = "lttng2-ust"
25RREPLACES_${PN} = "lttng2-ust"
26RCONFLICTS_${PN} = "lttng2-ust"
27
28PE = "2"
29
30SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
31 file://0001-python-lttngust-Makefile.am-Add-install-lib-to-setup.patch \
32 "
33
34SRC_URI[md5sum] = "99823cfeb76562d753ffe67880e9cc59"
35SRC_URI[sha256sum] = "683280cfe5e12021e64c32cef9eeb0128f1f23dec32ba28adb5a2074be37c4d8"
36
37CVE_PRODUCT = "ust"
38
39PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
40PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3"
41
42FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*"
43FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a"
44FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la"
45
46do_install_append() {
47 # Patch python tools to use Python 3; they should be source compatible, but
48 # still refer to Python 2 in the shebang
49 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
50}