summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-09-18 21:28:01 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-19 10:54:32 +0100
commitf700a98f20b261207c40fbcc7bdcb83e154b9534 (patch)
tree9845de969581d303080e92d4dd05c1d58163109b /meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb
parentc2f785f716c1add14252f22f50e0b6f4ddca3851 (diff)
downloadpoky-f700a98f20b261207c40fbcc7bdcb83e154b9534.tar.gz
lttng-ust: Upgrade 2.10.4 -> 2.10.5
Remove patch for issue fixed upstream. (From OE-Core rev: 1c8201da33174368fe7143047147d7c5aab0d224) Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb b/meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb
new file mode 100644
index 0000000000..e8312afb26
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.10.5.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
12 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
13 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
14"
15
16inherit autotools lib_package manpages python3native
17
18DEPENDS = "liburcu util-linux"
19RDEPENDS_${PN}-bin = "python3-core"
20
21# For backwards compatibility after rename
22RPROVIDES_${PN} = "lttng2-ust"
23RREPLACES_${PN} = "lttng2-ust"
24RCONFLICTS_${PN} = "lttng2-ust"
25
26PE = "2"
27
28SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
29 file://lttng-ust-doc-examples-disable.patch \
30 "
31
32SRC_URI[md5sum] = "f0c86a9fa7dcfd0205fb42584a310b1c"
33SRC_URI[sha256sum] = "06f9ed9b2198855b1c7fcbf15fe57297ee259409ffa1b3bad87321412d98bc35"
34
35CVE_PRODUCT = "ust"
36
37PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
38PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3"
39
40FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*"
41FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a"
42FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la"
43
44do_install_append() {
45 # Patch python tools to use Python 3; they should be source compatible, but
46 # still refer to Python 2 in the shebang
47 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
48}