diff options
author | Ross Burton <ross.burton@intel.com> | 2018-03-15 14:58:54 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-03-20 09:59:31 +0000 |
commit | 38e0189fae190e9e02da485b4e84bbc57504dd34 (patch) | |
tree | 788db20e1a1744dd4add782606151ab3e1ea615d /meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb | |
parent | 42a0e944a4a22e2b3b7c448ebaa540b8c774b5a8 (diff) | |
download | poky-38e0189fae190e9e02da485b4e84bbc57504dd34.tar.gz |
Revert "lttng-tools: Upgrade 2.9.5 -> 2.10.2"
None of the test suite works, so something quite fundamental broke.
[ YOCTO #12606 ]
This reverts commit 406ea737f1ce5bb5fed46c8cbeb5c7c13bf3b8ad.
(From OE-Core rev: 72a0b56757da98fcbf42bebb2f376738c68d3834)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb')
-rw-r--r-- | meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb | 123 |
1 files changed, 123 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb b/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb new file mode 100644 index 0000000000..93626dd4b5 --- /dev/null +++ b/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb | |||
@@ -0,0 +1,123 @@ | |||
1 | SECTION = "devel" | ||
2 | SUMMARY = "Linux Trace Toolkit Control" | ||
3 | DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \ | ||
4 | to extract program execution details from the Linux operating system \ | ||
5 | and interpret them." | ||
6 | |||
7 | LICENSE = "GPLv2 & LGPLv2.1" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \ | ||
9 | file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
10 | file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca" | ||
11 | |||
12 | DEPENDS = "liburcu popt libxml2 util-linux" | ||
13 | RDEPENDS_${PN} = "libgcc" | ||
14 | RDEPENDS_${PN}-ptest += "make perl bash gawk ${PN} babeltrace procps" | ||
15 | # babelstats.pl wants getopt-long | ||
16 | RDEPENDS_${PN}-ptest += "perl-module-getopt-long" | ||
17 | |||
18 | PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \ | ||
19 | am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \ | ||
20 | PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \ | ||
21 | " | ||
22 | PACKAGECONFIG ??= "lttng-ust" | ||
23 | PACKAGECONFIG[python] = "--enable-python-bindings ${PYTHON_OPTION},,python3 swig-native" | ||
24 | PACKAGECONFIG[lttng-ust] = "--with-lttng-ust, --without-lttng-ust, lttng-ust" | ||
25 | PACKAGECONFIG[kmod] = "--enable-kmod, --disable-kmod, kmod" | ||
26 | PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native" | ||
27 | PACKAGECONFIG_remove_libc-musl = "lttng-ust" | ||
28 | PACKAGECONFIG_remove_riscv64 = "lttng-ust" | ||
29 | |||
30 | SRC_URI = "https://lttng.org/files/lttng-tools/lttng-tools-${PV}.tar.bz2 \ | ||
31 | file://x32.patch \ | ||
32 | file://run-ptest \ | ||
33 | " | ||
34 | |||
35 | SRC_URI[md5sum] = "051224eb991aee07f8721ff1877d0b96" | ||
36 | SRC_URI[sha256sum] = "77839eb6fc6c652125f08acfd9369701c2516eb05cc2084160e7efc7a3fb731c" | ||
37 | |||
38 | inherit autotools ptest pkgconfig useradd python3-dir manpages | ||
39 | |||
40 | USERADD_PACKAGES = "${PN}" | ||
41 | GROUPADD_PARAM_${PN} = "tracing" | ||
42 | |||
43 | FILES_${PN} += "${libdir}/lttng/libexec/* ${datadir}/xml/lttng \ | ||
44 | ${PYTHON_SITEPACKAGES_DIR}/*" | ||
45 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a" | ||
46 | FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la" | ||
47 | |||
48 | # Since files are installed into ${libdir}/lttng/libexec we match | ||
49 | # the libexec insane test so skip it. | ||
50 | # Python module needs to keep _lttng.so | ||
51 | INSANE_SKIP_${PN} = "libexec dev-so" | ||
52 | INSANE_SKIP_${PN}-dbg = "libexec" | ||
53 | |||
54 | do_install_ptest () { | ||
55 | for f in Makefile tests/Makefile tests/utils/utils.sh ; do | ||
56 | install -D "${B}/$f" "${D}${PTEST_PATH}/$f" | ||
57 | done | ||
58 | |||
59 | for f in config/tap-driver.sh config/test-driver ; do | ||
60 | install -D "${S}/$f" "${D}${PTEST_PATH}/$f" | ||
61 | done | ||
62 | |||
63 | # Prevent 'make check' from recursing into non-test subdirectories. | ||
64 | sed -i -e 's!^SUBDIRS = .*!SUBDIRS = tests!' "${D}${PTEST_PATH}/Makefile" | ||
65 | |||
66 | # We don't need these | ||
67 | sed -i -e '/dist_noinst_SCRIPTS = /,/^$/d' "${D}${PTEST_PATH}/tests/Makefile" | ||
68 | |||
69 | # We shouldn't need to build anything in tests/utils | ||
70 | sed -i -e 's!am__append_1 = . utils!am__append_1 = . !' \ | ||
71 | "${D}${PTEST_PATH}/tests/Makefile" | ||
72 | |||
73 | # Copy the tests directory tree and the executables and | ||
74 | # Makefiles found within. | ||
75 | for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do | ||
76 | install -d "${D}${PTEST_PATH}/tests/$d" | ||
77 | find "${B}/tests/$d" -maxdepth 1 -executable -type f \ | ||
78 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} + | ||
79 | test -r "${B}/tests/$d/Makefile" && \ | ||
80 | install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile" | ||
81 | done | ||
82 | |||
83 | # We shouldn't need to build anything in tests/regression/tools | ||
84 | sed -i -e 's!^SUBDIRS = tools !SUBDIRS = !' \ | ||
85 | "${D}${PTEST_PATH}/tests/regression/Makefile" | ||
86 | |||
87 | # Prevent attempts to update Makefiles during test runs, and | ||
88 | # silence "Making check in $SUBDIR" messages. | ||
89 | find "${D}${PTEST_PATH}" -name Makefile -type f -exec \ | ||
90 | sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \ | ||
91 | -e '/echo "Making $$target in $$subdir"; \\/d' \ | ||
92 | -e 's/^srcdir = \(.*\)/srcdir = ./' \ | ||
93 | -e 's/^builddir = \(.*\)/builddir = ./' \ | ||
94 | -e 's/^all-am:.*/all-am:/' \ | ||
95 | {} + | ||
96 | |||
97 | # These objects trigger [rpaths] QA checks; the test harness | ||
98 | # skips the associated tests if they're missing, so delete | ||
99 | # them. | ||
100 | objs="" | ||
101 | objs="$objs regression/ust/ust-dl/libbar.so" | ||
102 | objs="$objs regression/ust/ust-dl/libfoo.so" | ||
103 | for obj in $objs ; do | ||
104 | rm -f "${D}${PTEST_PATH}/tests/${obj}" | ||
105 | done | ||
106 | |||
107 | find "${D}${PTEST_PATH}" -name Makefile -type f -exec \ | ||
108 | touch -r "${B}/Makefile" {} + | ||
109 | |||
110 | # Substitute links to installed binaries. | ||
111 | for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd ; do | ||
112 | exedir="${D}${PTEST_PATH}/src/bin/${prog}" | ||
113 | install -d "$exedir" | ||
114 | case "$prog" in | ||
115 | lttng-consumerd) | ||
116 | ln -s "${libdir}/lttng/libexec/$prog" "$exedir" | ||
117 | ;; | ||
118 | *) | ||
119 | ln -s "${bindir}/$prog" "$exedir" | ||
120 | ;; | ||
121 | esac | ||
122 | done | ||
123 | } | ||