summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb
diff options
context:
space:
mode:
authorNathan Lynch <nathan_lynch@mentor.com>2017-01-16 12:51:45 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:47:21 +0000
commit9ba3f6d20fdcf3cd29029ec8bd3ce201523018be (patch)
tree1a5a9297a9a854a710c3991ac9bbc0f959f3b81f /meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb
parent493af5a84c50c93bca097f91f5e62ffeafb13a15 (diff)
downloadpoky-9ba3f6d20fdcf3cd29029ec8bd3ce201523018be.tar.gz
lttng-tools: upgrade to 2.9.3
Notable recipe changes: * switch to using release tarball * brokensep no longer required * drop upstreamed error.h patch * change do_install_ptest to selectively copy build artifacts to install tree. * use backported patch to address file-rdeps warning (From OE-Core rev: 0846aaa429a18557129579260ff09c0145aba903) Signed-off-by: Nathan Lynch <nathan_lynch@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb127
1 files changed, 127 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb b/meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb
new file mode 100644
index 0000000000..741d884d9c
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.9.3.bb
@@ -0,0 +1,127 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit Control"
3DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \
4to extract program execution details from the Linux operating system \
5and interpret them."
6
7LICENSE = "GPLv2 & LGPLv2.1"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \
9 file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca"
11
12DEPENDS = "liburcu popt libxml2 util-linux"
13RDEPENDS_${PN} = "libgcc"
14RDEPENDS_${PN}-ptest += "make perl bash gawk ${PN} babeltrace procps"
15# babelstats.pl wants getopt-long
16RDEPENDS_${PN}-ptest += "perl-module-getopt-long"
17
18PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
19 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
20 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
21"
22PACKAGECONFIG ??= "lttng-ust"
23PACKAGECONFIG[python] = "--enable-python-bindings ${PYTHON_OPTION},,python3 swig-native"
24PACKAGECONFIG[lttng-ust] = "--with-lttng-ust, --without-lttng-ust, lttng-ust"
25PACKAGECONFIG[kmod] = "--enable-kmod, --disable-kmod, kmod"
26PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
27PACKAGECONFIG_remove_libc-musl = "lttng-ust"
28
29SRC_URI = "https://lttng.org/files/lttng-tools/lttng-tools-${PV}.tar.bz2 \
30 file://x32.patch \
31 file://utils-remove-bogus-interpreter.patch \
32 file://run-ptest"
33
34SRC_URI[md5sum] = "19fdcc5e9c307ef66581a2743a08a541"
35SRC_URI[sha256sum] = "a6e6baaaa977dcbc9bce6b675881eec664599b86f0d905a7b0b508539407b24e"
36
37inherit autotools ptest pkgconfig useradd python3-dir manpages
38
39USERADD_PACKAGES = "${PN}"
40GROUPADD_PARAM_${PN} = "tracing"
41
42FILES_${PN} += "${libdir}/lttng/libexec/* ${datadir}/xml/lttng \
43 ${PYTHON_SITEPACKAGES_DIR}/*"
44FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
45FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
46
47# Since files are installed into ${libdir}/lttng/libexec we match
48# the libexec insane test so skip it.
49# Python module needs to keep _lttng.so
50INSANE_SKIP_${PN} = "libexec dev-so"
51INSANE_SKIP_${PN}-dbg = "libexec"
52
53do_configure_prepend () {
54 # Delete a shipped m4 file that overrides our patched one
55 rm -f ${S}/m4/libxml.m4
56}
57
58do_install_ptest () {
59 for f in Makefile tests/Makefile tests/utils/utils.sh ; do
60 install -D "${B}/$f" "${D}${PTEST_PATH}/$f"
61 done
62
63 for f in config/tap-driver.sh config/test-driver ; do
64 install -D "${S}/$f" "${D}${PTEST_PATH}/$f"
65 done
66
67 # Prevent 'make check' from recursing into non-test subdirectories.
68 sed -i -e 's!^SUBDIRS = .*!SUBDIRS = tests!' "${D}${PTEST_PATH}/Makefile"
69
70 # We don't need these
71 sed -i -e '/dist_noinst_SCRIPTS = /,/^$/d' "${D}${PTEST_PATH}/tests/Makefile"
72
73 # We shouldn't need to build anything in tests/utils
74 sed -i -e 's!am__append_1 = . utils!am__append_1 = . !' \
75 "${D}${PTEST_PATH}/tests/Makefile"
76
77 # Copy the tests directory tree and the executables and
78 # Makefiles found within.
79 for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do
80 install -d "${D}${PTEST_PATH}/tests/$d"
81 find "${B}/tests/$d" -maxdepth 1 -executable -type f \
82 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
83 test -r "${B}/tests/$d/Makefile" && \
84 install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile"
85 done
86
87 # We shouldn't need to build anything in tests/regression/tools
88 sed -i -e 's!^SUBDIRS = tools !SUBDIRS = !' \
89 "${D}${PTEST_PATH}/tests/regression/Makefile"
90
91 # Prevent attempts to update Makefiles during test runs, and
92 # silence "Making check in $SUBDIR" messages.
93 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
94 sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \
95 -e '/echo "Making $$target in $$subdir"; \\/d' \
96 -e 's/^srcdir = \(.*\)/srcdir = ./' \
97 -e 's/^builddir = \(.*\)/builddir = ./' \
98 -e 's/^all-am:.*/all-am:/' \
99 {} +
100
101 # These objects trigger [rpaths] QA checks; the test harness
102 # skips the associated tests if they're missing, so delete
103 # them.
104 objs=""
105 objs="$objs regression/ust/ust-dl/libbar.so"
106 objs="$objs regression/ust/ust-dl/libfoo.so"
107 for obj in $objs ; do
108 rm -f "${D}${PTEST_PATH}/tests/${obj}"
109 done
110
111 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
112 touch -r "${B}/Makefile" {} +
113
114 # Substitute links to installed binaries.
115 for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd ; do
116 exedir="${D}${PTEST_PATH}/src/bin/${prog}"
117 install -d "$exedir"
118 case "$prog" in
119 lttng-consumerd)
120 ln -s "${libdir}/lttng/libexec/$prog" "$exedir"
121 ;;
122 *)
123 ln -s "${bindir}/$prog" "$exedir"
124 ;;
125 esac
126 done
127}