summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-11-09 11:34:59 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-04 17:23:59 +0000
commit7e0b00fd120375d6ae4b53a76e9120ee925d3629 (patch)
tree9d2215fd9b0bf3be7457e2bf438e74a6bf65c3f7 /meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb
parent25c0d7d891077889a7d1d0c437a399941989db61 (diff)
downloadpoky-7e0b00fd120375d6ae4b53a76e9120ee925d3629.tar.gz
lttng-modules: Upgrade to 2.9.5 release
This upgrade is critical as it fixes the support for Linux 4.14 LTS kernel. The changlog is: 2017-10-05 LTTng modules 2.9.5 * Fix: update block instrumentation for 4.14 kernel * Revert "Fix: update block instrumentation for kernel 4.14" 2017-10-03 (National Techies Day) LTTng modules 2.9.4 * Fix: version check error in btrfs instrumentation * Fix: update btrfs instrumentation for kernel 4.14 * Fix: update writeback instrumentation for kernel 4.14 * Fix: update block instrumentation for kernel 4.14 * Fix: vmalloc wrapper on kernel < 2.6.38 * Fix: vmalloc wrapper on kernel >= 4.12 * Add kmalloc failover to vmalloc * Fix: mmap: caches aliased on virtual addresses * Fix: update ext4 instrumentation for kernel 4.13 * Fix: Sleeping function called from invalid context * Fix: sched for v4.11.5-rt1 * Fix: handle missing ftrace header on v4.12 This also removes the previously backported patches as they are part of 2.9.4 release and the missing fix is part of 2.9.5 release. (From OE-Core rev: 56d01657934fe6e9e6c547fd58447c6a99a0779b) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb b/meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb
new file mode 100644
index 0000000000..61d97442d5
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.9.5.bb
@@ -0,0 +1,34 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=362844633a08753bd96ab322a6c7f9f6 \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9inherit module
10
11COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
12
13SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
14 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
15 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
16"
17
18SRC_URI[md5sum] = "af97aaaf86133fd783bb9937dc3b4d59"
19SRC_URI[sha256sum] = "3f4e82ceb1c3c1875ec1fe89fba08294ed7feec2161339a5a71a066b27fc3e22"
20
21export INSTALL_MOD_DIR="kernel/lttng-modules"
22
23EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
24
25do_install_append() {
26 # Delete empty directories to avoid QA failures if no modules were built
27 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
28}
29
30python do_package_prepend() {
31 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
32 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
33}
34