summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-05-12 12:02:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-16 22:31:50 +0100
commitcdf81801ba10caa87b857a2c345405e6a7db2547 (patch)
tree095e8e43a42eb9b46188b448e72221bfb2f42821 /meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
parente5f9a2cbe7f9ace072f0eaf1f9d51886a70c561b (diff)
downloadpoky-cdf81801ba10caa87b857a2c345405e6a7db2547.tar.gz
lttng-modules: Update to stable version 2.6.1
This fixes a build issue with the 3.19.5 kernel where the regmap prototypes have changed. The patch is rebased do to changes in the new version of the Makefile. [YOCTO #7737] (From OE-Core rev: 787fde133c6b50c5df6ce8f90b2906b7955b41e4) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
new file mode 100644
index 0000000000..be09a82f82
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
@@ -0,0 +1,34 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9inherit module
10
11SRCREV = "62080b2248fd8ec4111ffc379d0bc5eaf0a5c16d"
12
13COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|arm).*-linux'
14
15SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6 \
16 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
17 "
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20export KERNEL_SRC="${STAGING_KERNEL_DIR}"
21
22
23S = "${WORKDIR}/git"
24
25do_install_append() {
26 # Delete empty directories to avoid QA failures if no modules were built
27 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
28}
29
30python do_package_prepend() {
31 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
32 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
33}
34