summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-03-18 11:32:01 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-22 23:17:27 +0000
commitfc363acc5be39897a130893d220cc3e93974b162 (patch)
tree5a8929cb42cb857178a0bc5d2483e7da77e7e360 /meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb
parent20dec1e5271942c2d0d3d10c5b63f9b0b79cc952 (diff)
downloadpoky-fc363acc5be39897a130893d220cc3e93974b162.tar.gz
lttng-modules: update to v2.13.9
Bumping lttng-modules to version v2.13.9-4-g12f43cab, which comprises the following commits: da1f5a26 Version 2.13.9 dc2d1294 fix: jbd2: use the correct print format (v5.4.229) d04c1211 fix: jbd2 upper bound for v5.10.163 4b8864fc fix: jbd2: use the correct print format (v5.10.163) 69d3aa79 fix: btrfs: move accessor helpers into accessors.h (v6.2) We drop our previously backported commits as well, since they are part of the release. (From OE-Core rev: 79d8e93adde07ff3a4a239d66649ee566a2437d6) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb
deleted file mode 100644
index c04796be16..0000000000
--- a/meta/recipes-kernel/lttng/lttng-modules_2.13.8.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
14 file://fix-jbd2-use-the-correct-print-format-v5.10.163.patch \
15 file://fix-jbd2-upper-bound-for-v5.10.163.patch \
16 file://0001-fix-btrfs-move-accessor-helpers-into-accessors.h-v6..patch \
17 "
18
19# Use :append here so that the patch is applied also when using devupstream
20SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
21
22SRC_URI[sha256sum] = "f525d3d48ea3a475cb535339c201666d0e4c75ec8c46d29837bcf381ea02cb19"
23
24export INSTALL_MOD_DIR="kernel/lttng-modules"
25
26EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
27
28MODULES_MODULE_SYMVERS_LOCATION = "src"
29
30do_install:append() {
31 # Delete empty directories to avoid QA failures if no modules were built
32 if [ -d ${D}/${nonarch_base_libdir} ]; then
33 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
34 fi
35}
36
37python do_package:prepend() {
38 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
39 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
40}
41
42BBCLASSEXTEND = "devupstream:target"
43SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
44SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
45SRCREV_FORMAT ?= "lttng_git"