summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-10-28 22:05:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 13:22:49 +0000
commit9624092cd61bdde9bcef3361cff898282e50dcae (patch)
treed962e774876b63c3acd3c5c7898d2cd15351e942 /meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
parent6d3c1edca59528ea8d0ed212729e6b689657eddb (diff)
downloadpoky-9624092cd61bdde9bcef3361cff898282e50dcae.tar.gz
lttng-modules: update 2.12.2 -> 2.12.3
Drop a pile of backports. (From OE-Core rev: fba843f79ac6ad2636385de2bd63e90e08c04fcd) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
new file mode 100644
index 0000000000..0b6a69ff5e
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.12.3.bb
@@ -0,0 +1,42 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9include lttng-platforms.inc
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 "
15
16SRC_URI[sha256sum] = "673ef85c9f03e9b8fed10795e09d4e68add39404b70068d08b10f7b85754d7f0"
17
18export INSTALL_MOD_DIR="kernel/lttng-modules"
19
20EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
21
22do_install_append() {
23 # Delete empty directories to avoid QA failures if no modules were built
24 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
25}
26
27python do_package_prepend() {
28 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
29 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
30}
31
32BBCLASSEXTEND = "devupstream:target"
33LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
34DEFAULT_PREFERENCE_class-devupstream = "-1"
35SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.12 \
36 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
37 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
38 "
39SRCREV_class-devupstream = "ad594e3a953db1b0c3c059fde45b5a5494f6be78"
40PV_class-devupstream = "2.12.2+git${SRCPV}"
41S_class-devupstream = "${WORKDIR}/git"
42SRCREV_FORMAT ?= "lttng_git"