summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2023-02-03 04:06:37 -1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-13 07:44:09 +0000
commitfb8372aa7032644a0808f06bdc5d62969604d4a6 (patch)
treeb9b01446efa1ae6514805374c16e0196eb823f5c /meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
parent4f6333a564f9ee3c789ce7476e4a9b6eb357d9a7 (diff)
downloadpoky-fb8372aa7032644a0808f06bdc5d62969604d4a6.tar.gz
lttng-modules: update 2.11.6 -> 2.11.7
2021-01-11 (National Clean Off Your Desk Day) LTTng modules 2.11.7 * fix: adjust version range for trace_find_free_extent() * fix: backport of fix: tracepoint: Optimize using static_call() (v5.10) * Revert "fix: include order for older kernels" * fix: backport of fix: ext4: fast commit recovery path (v5.10) * Improve the release script * Add release maintainer script * fix: include order for older kernels * fix: tracepoint: Optimize using static_call() (v5.10) * fix: KVM: x86/mmu: Return unique RET_PF_* values if the fault was fixed (v5.10) * fix: kvm: x86/mmu: Add TDP MMU PF handler (v5.10) * fix: KVM: x86: Add intr/vectoring info and error code to kvm_exit tracepoint (v5.10) * fix: ext4: fast commit recovery path (v5.10) * fix: btrfs: make ordered extent tracepoint take btrfs_inode (v5.10) * fix: btrfs: tracepoints: output proper root owner for trace_find_free_extent() (v5.10) * fix: objtool: Rename frame.h -> objtool.h (v5.10) * fix: strncpy equals destination size warning Remove patches now included in 2.11.7 (From OE-Core rev: f3c18d4eda42debf40dcd7de02b2f761c476dcca) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
deleted file mode 100644
index 76b9f13618..0000000000
--- a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPLv2.1 & GPLv2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
7
8inherit module
9
10COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
14 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
15 file://0001-fix-strncpy-equals-destination-size-warning.patch \
16 file://0002-fix-objtool-Rename-frame.h-objtool.h-v5.10.patch \
17 file://0003-fix-btrfs-tracepoints-output-proper-root-owner-for-t.patch \
18 file://0004-fix-btrfs-make-ordered-extent-tracepoint-take-btrfs_.patch \
19 file://0005-fix-ext4-fast-commit-recovery-path-v5.10.patch \
20 file://0006-fix-KVM-x86-Add-intr-vectoring-info-and-error-code-t.patch \
21 file://0007-fix-kvm-x86-mmu-Add-TDP-MMU-PF-handler-v5.10.patch \
22 file://0008-fix-KVM-x86-mmu-Return-unique-RET_PF_-values-if-the-.patch \
23 file://0009-fix-tracepoint-Optimize-using-static_call-v5.10.patch \
24 file://0010-fix-include-order-for-older-kernels.patch \
25 file://0011-Add-release-maintainer-script.patch \
26 file://0012-Improve-the-release-script.patch \
27 file://0013-fix-backport-of-fix-ext4-fast-commit-recovery-path-v.patch \
28 file://0014-Revert-fix-include-order-for-older-kernels.patch \
29 file://0015-fix-backport-of-fix-tracepoint-Optimize-using-static.patch \
30 file://0016-fix-adjust-version-range-for-trace_find_free_extent.patch \
31 file://0017-fix-random-remove-unused-tracepoints-v5.18.patch \
32 file://0018-fix-random-remove-unused-tracepoints-v5.10-v5.15.patch \
33 file://0019-fix-random-tracepoints-removed-in-stable-kernels.patch \
34 "
35
36SRC_URI[md5sum] = "8ef09fdfcdec669d33f7fc1c1c80f2c4"
37SRC_URI[sha256sum] = "23372811cdcd2ac28ba8c9d09484ed5f9238cfbd0043f8c663ff3875ba9c8566"
38
39export INSTALL_MOD_DIR="kernel/lttng-modules"
40
41EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
42
43do_install_append() {
44 # Delete empty directories to avoid QA failures if no modules were built
45 if [ -d ${D}/${nonarch_base_libdir} ]; then
46 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
47 fi
48}
49
50python do_package_prepend() {
51 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
52 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
53}
54
55BBCLASSEXTEND = "devupstream:target"
56LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
57DEFAULT_PREFERENCE_class-devupstream = "-1"
58SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \
59 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
60 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
61 "
62SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955"
63PV_class-devupstream = "2.11.2+git${SRCPV}"
64S_class-devupstream = "${WORKDIR}/git"
65SRCREV_FORMAT ?= "lttng_git"