summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2020-10-06 14:11:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-15 13:45:49 +0100
commitd748312f7a29f7bbef435ce8bf7f63f3c0657a8b (patch)
tree63a3923dc0542462d797bc13d533bf4cbeedbd83 /meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
parentf5497978c5c4fd4ce5812d9ea97fa4f97b1ee77b (diff)
downloadpoky-d748312f7a29f7bbef435ce8bf7f63f3c0657a8b.tar.gz
lttng-modules: update to 2.11.6
Update to latest available. (From OE-Core rev: 3ba57b15b1eeb0756ab9bc6b317ead1a7a08d226) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Alexander Kanavin <alex.kanavin@gmail.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
new file mode 100644
index 0000000000..a38d8afb7a
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
@@ -0,0 +1,43 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 "
15
16SRC_URI[md5sum] = "8ef09fdfcdec669d33f7fc1c1c80f2c4"
17SRC_URI[sha256sum] = "23372811cdcd2ac28ba8c9d09484ed5f9238cfbd0043f8c663ff3875ba9c8566"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20
21EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
22
23do_install_append() {
24 # Delete empty directories to avoid QA failures if no modules were built
25 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
26}
27
28python do_package_prepend() {
29 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
30 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
31}
32
33BBCLASSEXTEND = "devupstream:target"
34LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
35DEFAULT_PREFERENCE_class-devupstream = "-1"
36SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \
37 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
38 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
39 "
40SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955"
41PV_class-devupstream = "2.11.2+git${SRCPV}"
42S_class-devupstream = "${WORKDIR}/git"
43SRCREV_FORMAT ?= "lttng_git"