summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb
diff options
context:
space:
mode:
authorDaniel Dragomir <Daniel.Dragomir@windriver.com>2020-03-18 16:42:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-21 22:39:00 +0000
commitecfeb0875d18d55e31218be5feb5a05de222e4c8 (patch)
treeb274811f0e8879a57ed1a5a22f19ea4beea2bfe9 /meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb
parentb52c45aa79bac6fcf95c176a2af2df3bee84c65e (diff)
downloadpoky-ecfeb0875d18d55e31218be5feb5a05de222e4c8.tar.gz
lttng-modules: update to 2.11.2
Upgrade to version 2.11.2 in order to fix some build errors with latest 5.4 kernel. - conflicting types for 'trace_fast_page_fault' Reproductible on kernel greater than v5.4.19, starting with commit 8a1cd01bee ("KVM: x86: Use gpa_t for cr2/gpa to fix TDP support on 32-bit KVM") Error messages: lttng-modules-2.11.1/probes/../probes/lttng-tracepoint-event-impl.h:130:6: error: 130 | void trace_##_name(_proto); tmp/work-shared/axxiax86-64/kernel-source/include/linux/tracepoint.h:233:21: note: previous definition of 'trace_fast_page_fault' was here 233 | static inline void trace_##name(proto) - conflicting types for 'trace_rcu_dyntick' Reproductible on kernel greater than v5.4.22, starting with commit 6cf539a87a ("rcu: Fix data-race due to atomic_t copy-by-value") Error messages: lttng-modules-2.11.1/probes/../probes/lttng-tracepoint-event-impl.h:130:6: error: conflicting types for 'trace_rcu_dyntick' 130 | void trace_##_name tmp/work-shared/axxiax86-64/kernel-source/include/linux/tracepoint.h:233:21: note: previous definition of 'trace_rcu_dyntick' was here 233 | static inline void trace_##name(proto) (From OE-Core rev: 8fcc33aea08fc1e82818893feb7b01c7cc1e6416) Signed-off-by: Daniel Dragomir <Daniel.Dragomir@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb
new file mode 100644
index 0000000000..6fff096a37
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.11.2.bb
@@ -0,0 +1,43 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 "
15
16SRC_URI[md5sum] = "2e3bc8cfb264fa13f374618b46f170e7"
17SRC_URI[sha256sum] = "8a42240813b8fd1d001835cd6f5ec687f7d7f3b26070d4e21604c35a51a6441d"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20
21EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
22
23do_install_append() {
24 # Delete empty directories to avoid QA failures if no modules were built
25 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
26}
27
28python do_package_prepend() {
29 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
30 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
31}
32
33BBCLASSEXTEND = "devupstream:target"
34LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
35DEFAULT_PREFERENCE_class-devupstream = "-1"
36SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \
37 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
38 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
39 "
40SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955"
41PV_class-devupstream = "2.11.2+git${SRCPV}"
42S_class-devupstream = "${WORKDIR}/git"
43SRCREV_FORMAT ?= "lttng_git"