summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-12 16:30:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:25:42 +0000
commit9fb6a66c79d5a421a1feddafd13047c288f3802e (patch)
tree54a1d960895ce4d7701b34f53b3c56519ca32d5d /meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb
parent588730900619ff3752cca5d24b9f72249d7680bc (diff)
downloadpoky-9fb6a66c79d5a421a1feddafd13047c288f3802e.tar.gz
lttng-modules: update to 2.11.0
License-Update: formatting, dropped the gpl texts, as they're not anymore in source tree, and the main file is specific enough. (From OE-Core rev: 15ca6acb87299ffc770d35b075024f0ccaace61f) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb
new file mode 100644
index 0000000000..3465a43d38
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.11.0.bb
@@ -0,0 +1,47 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
6
7inherit module
8
9COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
10
11SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
13 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
14 file://0001-Fix-SUNRPC-Fix-oops-when-trace-sunrpc_task-events-in.patch \
15 file://0002-Fix-sunrpc-null-rpc_clnt-dereference-in-rpc_task_que.patch \
16 file://0003-Fix-sunrpc-use-signed-integer-for-client-id.patch \
17 file://0004-sunrpc-introduce-lttng_get_clid-helper.patch \
18 "
19
20SRC_URI[md5sum] = "46ec6c566e65cf27b391a1bb643e11b4"
21SRC_URI[sha256sum] = "98af92d8c2e00f4eb63bc637a6967103cf6997434493f36e7a535a491e4fad5f"
22
23export INSTALL_MOD_DIR="kernel/lttng-modules"
24
25EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
26
27do_install_append() {
28 # Delete empty directories to avoid QA failures if no modules were built
29 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
30}
31
32python do_package_prepend() {
33 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
34 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
35}
36
37BBCLASSEXTEND = "devupstream:target"
38LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3"
39DEFAULT_PREFERENCE_class-devupstream = "-1"
40SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.10 \
41 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
42 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
43 "
44SRCREV_class-devupstream = "624aca5d7507fbd11ea4a1a474c3aa1031bd9a31"
45PV_class-devupstream = "2.10.10+git${SRCPV}"
46S_class-devupstream = "${WORKDIR}/git"
47SRCREV_FORMAT ?= "lttng_git"